Using Caddy with Express VPN

1. Caddy version (caddy version): 2.1.1

2. How I run Caddy:

I use Caddy to create a reverse proxy for Ombi. I have my own domain and setup a DNS query for

a. System environment:

I use Windows 10 Home to run Caddy for Ombi.

d. My complete Caddyfile or JSON config: {

3. The problem I’m having:

I use Deluge as a torrent client and have Sonarr, Radarr and Jackett installed as well. I tried to use the split tunneling feature on ExpressVPN to prevent Ombi and Caddy from being encrypted in the VPN. When the VPN is off, everything works as intended. When I start the VPN, Caddy starts, but i get a constant loading from the borwser trying to access Ombi at my domain.

I also cannot seem to to get Caddy to properly start with Windows.

5. What I already tried:

I have tried changing applications and managing the split tunneling feature with Express VPN.

I tried using NSSM and a .bat file to start Caddy.

Here is the error I keep getting when I turn on the VPN even though Caddy and Ombi and Dynu IP are all set to NOT use the VPN. I also have a windows firewall rule set to accept all 80 and 443 port connections. And I have the VPN set to allow all LAN connections.

ERROR http.log.error dial tcp connectex: The requested address is not valid in its context. {“request”: {“method”: “GET”, “uri”: “/”, “proto”: “HTTP/1.1”, “remote_addr”: “”, “host”: “”, “headers”: {“Accept-Encoding”: [“gzip, deflate, br”], “Accept-Language”: [“en-US,en;q=0.9”], “Cache-Control”: [“max-age=0”], “Accept”: [“text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,/;q=0.8,application/signed-exchange;v=b3;q=0.9”], “Sec-Fetch-User”: ["?1"], “Sec-Fetch-Dest”: [“document”], “User-Agent”: [“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.105 Safari/537.36”], “Sec-Fetch-Site”: [“cross-site”], “Sec-Fetch-Mode”: [“navigate”], “Connection”: [“keep-alive”], “Upgrade-Insecure-Requests”: [“1”], “Dnt”: [“1”]}, “tls”: {“resumed”: false, “version”: 771, “ciphersuite”: 49196, “proto”: “http/1.1”, “proto_mutual”: true, “server_name”: “”}}, “duration”: 0, “status”: 502, “err_id”: “zz3dg8jft”, “err_trace”: “reverseproxy.(*Handler).ServeHTTP (reverseproxy.go:411)”}

This topic was automatically closed after 30 days. New replies are no longer allowed.