[reverse proxy] Caddy redirecting correctly, site still NOT secure

1. Caddy version (caddy version):


2. How I run Caddy:

sudo caddy start (Ubuntu command line)

a. System environment:

Ubuntu, NOT a docker install

b. Command:

sudo caddy start

c. Service/unit/compose file:


d. My complete Caddyfile or JSON config:

# The Caddyfile is an easy way to configure your Caddy web server.
# Unless the file starts with a global options block, the first
# uncommented line is always the address of your site.

http://www.xxxxs.tk {


3. The problem I’m having:

redirect a URL to the specific port I have setup for a Jellyfin media server and provide HTTPS security, the redirect is happening but the site is still not secure (no HTTPS).

4. Error messages and/or full log output:

EDIT: Found this as I was looking through console messages:

http    server is listening only on the HTTP port, so no automatic HTTPS will be applied to this server {"server_name": "srv0", "http_port": 80}


5. What I already tried:

I’ve checked and rechecked the DNS settings, the Caddyfile, and the console feedback on startup. I have ALLOWED ports 443 and 80 through the Ubuntu firewall.

6. Links to relevant resources:

Replying to my own post as I have solved it (not deleting it in case my mistake is made by others).

Caddyfile should NOT contain “http://” before the URL or (it seems) caddy will ONLY listen on the HTTP port and not automatically create HTTPS for you.

1 Like

Thanks for sharing the solution!

Indeed, specifying http:// means that Caddy will do what you say, and serve only HTTP, not HTTPS. Caddyfile Concepts — Caddy Documentation

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.