Caddy reverse proxy working but not HTTPS

1. Caddy version (caddy version):

most recent

2. How I run Caddy:

as a service

a. System environment:

Ubuntu 18

b. Command:

c. Service/unit/compose file:

paste full file contents here

d. My complete Caddyfile or JSON config:    {



3. The problem I’m having:

Redirect to the port happens but NOT secured.

4. Error messages and/or full log output:

5. What I already tried:

I’ve had Caddy working great for reverse proxy and SSL for a long time. Today I did a sudo apt upgrade to get the server up to date. Everything seems to be working except now there’s no SSL.

6. Links to relevant resources:

Well, you did put http:// in front of your domain, so of course it won’t serve HTTPS!

You know what’s worse than making such a silly mistake? I’ve made it and posted about it before. If I were you, I’d ban me.



It’s actually your 3rd time, one in each of the threads you’ve posted

But no worries, hopefully you’ve fixed it once and for all.

This topic was automatically closed after 30 days. New replies are no longer allowed.