Migrating CaddyV2 to Unraid Docker CaddyV2

1. Caddy version (caddy version):

caddy:alpine or CaddyV2

2. How I run Caddy:

Unraid Docker CaddyV2

a. System environment:


b. Command:

paste command here

c. Service/unit/compose file:

paste full file contents here

d. My complete Caddyfile or JSON config:

paste config here, replacing this text
DO NOT REDACT anything except credentials

3. The problem I’m having:

Have caddyv2 running on windows 10 server working perfect, want to decommission this box so thought to run caddyv2 on my unraid Nas.

4. Error messages and/or full log output:

{“level”:“info”,“ts”:1606114549.437499,“logger”:“tls.obtain”,“msg”:“releasing lock”,“identifier”:“mydomain.com”}
{“level”:“error”,“ts”:1606114549.4401119,“logger”:“tls”,“msg”:“job failed”,“error”:“mydomain.com: obtaining certificate: [mydomain.com] Obtain: [mydomain.com] creating new order: request to https://acme-v02.api.letsencrypt.org/acme/new-order failed after 1 attempts: HTTP 400 urn:ietf:params:acme:error:malformed - JWS verification error (ca=https://acme-v02.api.letsencrypt.org/directory)”}

5. What I already tried:

waiting, restarting, etc

6. Links to relevant resources:

This is not th first time I’ve seen a jws verification error… So now I’m intrigued, but I’ll need more information. How can I set up a server and get the same error you are?

Hey Matt
You could install the trial version of UnRAID Unraid | Purchase Unraid OS and then go through and install the CaddyV2 docker container.

So using unraid and the docker container are required to reproduce the error? :confused:

That’s a lot to ask, so if you can simplify it that will speed things up. I won’t have time to go through all those steps – nor do I want to start a trial on some service – so if you can reproduce the error without unraid + docker, that would be helpful. (Basically, you’re on your own unless it can become easier to replicate.)


I recreated the container without a specific container path to the Caddyfile which was in the docker template by default. then i navigated to the /etc/caddy/Caddyfile location and added my configuration to the Caddyfile and it worked fine. only annoying thing is that anytime i want to update the Caddyfile i have to go through the console and then navigate to /etc/caddy/Caddyfile to edit the caddyfile. i’d rather be able to navigate through a GUI and edit with notepad or such.


1 Like

Unraid’s Docker stuff probably lets you set up volumes; set one up to use your Caddyfile that you have on the host machine.

Also, please remember to persist the /data volume, otherwise you’ll be losing your certs and keys every time the container is recreated.

1 Like

Matt, Francis, you are gentlemen and scholars!


This topic was automatically closed after 30 days. New replies are no longer allowed.