Caddy bring up weird error about pb.proto

1. Caddy version (caddy version): v2.1.0

2. How I run Caddy:Ubuntu 20.04 LTS with the default apt install from the guides section

a. System environment: Ubuntu 20.04 LTS, Systemd, apt install

b. Command: any caddy command brings up the error

any caddy command brings up the error

c. Service/unit/compose file:

# For using Caddy with a config file.
# Make sure the ExecStart and ExecReload commands are correct
# for your installation.
# See for instructions.
# WARNING: This service does not use the --resume flag, so if you
# use the API to make changes, they will be overwritten by the
# Caddyfile next time the service is restarted. If you intend to
# use Caddy's API to configure it, add the --resume flag to the
# `caddy run` command or use the caddy-api.service file instead.


ExecStart=/usr/bin/caddy run --environ --config /etc/caddy/Caddyfile
ExecReload=/usr/bin/caddy reload --config /etc/caddy/Caddyfile

d. My complete Caddyfile or JSON config:

# The Caddyfile is an easy way to configure your Caddy web server.
# Unless the file starts with a global options block, the first
# uncommented line is always the address of your site.
# To use your own domain name (with automatic HTTPS), first make
# sure your domain's A/AAAA DNS records are properly pointed to
# this machine's public IP, then replace the line below with your
# domain name.

# Set this path to your site's directory.
root * /usr/share/caddy

# Enable the static file server.

# Another common task is to set up a reverse proxy:
# reverse_proxy localhost:8080

# Or serve a PHP site through php-fpm:
# php_fastcgi localhost:9000

# Refer to the Caddy docs for more information:

3. The problem I’m having: Whenever I run any caddy command I get an error talking about something I don’t understand at all and google yields zero results

4. Error messages and/or full log output:

myusername@myhostname:~$ caddy
2020/06/29 19:07:12 WARNING: proto: file “pb.proto” is already registered
A future release will panic on registration conflicts. See:

Caddy is an extensible server platform.

caddy [<args…>]

adapt Adapts a configuration to Caddy’s native JSON
build-info Prints information about this build
environ Prints the environment
file-server Spins up a production-ready file server
fmt Formats a Caddyfile
hash-password Hashes a password and writes base64
help Shows help for a Caddy subcommand
list-modules Lists the installed Caddy modules
reload Changes the config of the running Caddy instance
reverse-proxy A quick and production-ready reverse proxy
run Starts the Caddy process and blocks indefinitely
start Starts the Caddy process in the background and then returns
stop Gracefully stops a started Caddy process
trust Installs a CA certificate into local trust stores
untrust Untrusts a locally-trusted CA certificate
validate Tests whether a configuration file is valid
version Prints the version

Use 'caddy help ’ for more information about a command.

Full documentation is available at:


5. What I already tried: Purging the install and trying it three times. Searching the pc for the file it’s talking about nothing comes up. looked all over google nothing comes up. Went to page it tells me to visit it made absolutely no sense to me.

6. Links to relevant resources:

I had this same question. Here’s the response

You shouldn’t need to worry about it.

Thanks for the response.

We’ll soon release a v2.1.1 that fixes this warning - it was an unintended regression from v2.0

This topic was automatically closed after 30 days. New replies are no longer allowed.