Question about pb.proto

1. Caddy version (caddy version):

v2.1.0 h1:MC4d65RCVaEKy1iOFjsD51mybOwS8qdEVBi7ESDhUfE=

2. How I run Caddy:

system service

a. System environment:

raspberry pi 4 (buster)
direct install

b. Command:

start or run

c. Service/unit/compose file:

n/a

d. My complete Caddyfile or JSON config:

The Caddyfile doesn’t matter as I tried different ones and it doesn’t stop the WARNING

mydomain.duckdns.org {
        root * /srv/dev-disk-by-label-HomeDrive/config files/users
        file_server browse
}

3. The problem I’m having:

I get the following every time I enter anything into the terminal with caddy

2020/06/27 08:43:08 WARNING: proto: file "pb.proto" is already registered
A future release will panic on registration conflicts. See:
https://developers.google.com/protocol-buffers/docs/reference/go/faq#namespace-conflict

This started after my upgrade to 2.1. The method of upgrading was using apt.

4. Error messages and/or full log output:

5. What I already tried:

I went to the link and read about it. It’s far above my head to understand though. I also found this issue already brought up on the GitHub https://github.com/caddyserver/caddy/issues/3525

Is this going to be an issue for my system? So far Caddy seems to be working just like it was for the guy who posted in GitHub. @Mohammed90 said it could be fixed by downgrading but I haven’t the slightest on how to do that.

Should I just leave it alone and wait for a fix? Any help would be great. Thank you.

6. Links to relevant resources:

You don’t have to worry about that. It won’t cause you any issues on your system, and Caddy will run fine anyways. The downgrading isn’t something for the end-user (you). It’s something for us to handle in the versions of the libraries used in Caddy.

1 Like

Good news. Thank you!