Wordpress strange behavior


first i want to thank you for amazing work in Caddy.

I began use Caddy this week in one site with Wordpress.

Everything is working, but Wordpress Admin is strange.
Some requests “freeze” and nothing happens.

When i reply one comment and press submit button, nothing happens, Doesn`t return or close textarea.
But when i refresh page, my comment appear.

Other thing, appear “error” msg in red below comment like this print:

I test admin more than one browser.

What can it be?


About this - and into - project by @Mauricio_Zane_Filho:

  1. I’ve tried to change fpm using socket to listening v4/v6 local port. - no changes or improvements
  2. “freezes” reminds client-side behaviour, not server-side. Anyway, with nginx, this behaviour we do not have it.
    2.1) And yes, we have tried to load a mime config by @electerious. Some times some dynamic files may be have issues (perhaps?)
  3. Into shell, many 504 and 502 issues from fpm - logs needed?
  4. Many times, Caddy is going down. A shell file called caddy-reload doesn’t work properly => bind at 80 and 443 already in use (annoying issue)


    echo "Stopping Caddy..."
    sudo service caddy stop;
    echo "Caddy stopped."
    echo "Setting ulimit over again..."
    ulimit -n 10240;
    echo "Daemon reload..."
    sudo systemctl daemon-reload;
    echo "Deamon reloaded."
    echo "Starting Caddy..."
    sudo service caddy start;
    echo "Caddy started."


    sudo caddy-stop;
    sudo caddy-daemon;
    ulimit -n 10240;
    export CLOUDFLARE_EMAIL=email@domain.tld;
    export CLOUDFLARE_API_KEY=bl4bl4bl4bl4bl4_API_CF_TOKEN;
    echo "Setting up all Let's Encrypt certificate for Caddy Server...";
    echo "registered email => \"email@domain.tld\"...";
    caddy --conf /etc/caddy/Caddyfile --agree=true --email 'email@domain.tld' & disown;
    sudo caddy-reload;
    sudo caddy-daemon;
    echo "WELL DONE!"`

note 01: with or without daemon-reload, doesn’t work properly
note 02: only after reboot, Caddy works with Cloudflare.

caddy[24364]: Activating privacy features… […] CloudFlare credentials missing

The dns cloudflare have been activated, indeed.

These things might tell us more about your problems - if you can post your:

  • Caddy version
  • Caddyfile
  • PHP version
  • Distro and release
  • Logs (PHP and Caddy)

I’ll take a look and try to find out what’s up.

@perroud looks like you’re having an issue with the variables not being set properly for the Caddy process. What distro/release are you running? Can you post the Caddy unit file you’re using for systemd? Also out of curiosity, why is the systemctl daemon-reload required in your caddy-reload file?

Caddy version:

downloaded from website, not from git. All options were selected.

Caddy file: @Mauricio_Zane_Filho, I do not have a valid .pem file from AWS anymore. copy/paste here, please.

PHP Version:


Distro and release:

Ubuntu 16.04.1

Logs: @Mauricio_Zane_Filho get’em logs, please.

Could this be related to https://github.com/mholt/caddy/issues/1204 ?