WordPress, phpMyAdmin and ownCloud login loop problem

pic 1:

pic 2:

I am using the latest version of WordPress, phpMyAdmin and ownCloud with Caddy 0.9.4 and PHP 7.0.14, but I could login to none of them. Every time I submit my username and password it brings me to the login page again. I have tried in many browsers for many times.

The session.save_path is /var/lib/php/session , and it belongs to www-data:www-data:

Thers’s nothing helpful in /var/log/php-fpm/error.log.

So what should I do?

Couple general things to look out for that can contribute to this issue, which is usually WordPress-specific (rather than a webserver issue):

  1. Have you tried to log in using an Incognito window?
  2. Have you tried navigating to /wp-admin/ directly after completing one of these login loops?
  3. Is the site URL in the WordPress database correctly set to the actual address serving WordPress?
  4. Are you using any extra themes or plugins?

If none of the above are applicable, you might want to define('WP_DEBUG', true); in your wp-config.php to investigate further.

I have tried Chrome Incognito mode, but nothing changes.
I navigated to /wp-admin after a loop, then it brought me back again.
The Site URL is correct.
I disabled all the plugins, but that didn’t make any different.
Although WP_DEBUG is enabled, there’s no error information in the page.

oh god…

And I found I can login WordPress in IE and an old version of Chrome (but the problem of phpMyAdmin still exists).

Hmm. What distro are you running this on?

The server is running Fedora 25.

Are you running Caddy with QUIC parameter?

Because if yes, this refers to my opened issue here.

That would explain, why you can login from IE, because it does not use QUIC, instead it uses TLS, in which logins are possible.

I have solved the problem by re-installing the php-fpm :grin: But as what you say, QUIC does cause login problems. Sometimes Caddy immediately crashes when I submit login form, so now I have disabled QUIC. Thanks.

How did you reinstall php-fpm? and php5-fpm or php7.0-fpm?

Uninstall it and then install it, just try my luck :yum: I guess the real cause of my problem is mistakes in my conf files.
I am using PHP 7.

Did reinstall PHP7.0-FPM by: apt-get --purge remove php7.0-fpm and apt-get install php7.0-fpm but I still experience the same error.

I mean it cannot be a solution to simply deactivate QUIC, there must be a way to use proper logins from popular open source webapps over QUIC with Caddy… Even GOOGLE sites served over QUIC are usable for logins.

Well, I read your GitHub issue. At first, ownCloud’s CSRF check failed is a very common error. It may not caused by QUIC or php-fpm. Then, try

fastcgi / php

in your Caddyfile (make sure the php-fpm is listening on port 9000).
At last, check if the session.save_path is valid, and the permission/owner of that path is right, which is important to the webapps using sessions to implement login function.
(and another possibility: the implementation of QUIC protocol of Caddy is buggy currently)
Good luck.

I have tried for many times, and now I found it is QUIC which cause these problems. When I post login form, Caddy crashes with this error information:

panic: interface conversion: io.ReadCloser is struct { io.Reader; io.Closer }, not *h2quic.requestBody

goroutine 244 [running]:
panic(0xdce060, 0xc4207acd40)
	/usr/local/go/src/runtime/panic.go:500 +0x1a1
github.com/lucas-clemente/quic-go/h2quic.(*Server).handleRequest.func1(0xc4203ee840, 0xc4203960a0, 0xc42045c000, 0x0, 0x137c740, 0xc42031aea0)
	/home/caddy/go/src/github.com/lucas-clemente/quic-go/h2quic/server.go:193 +0x17c
created by github.com/lucas-clemente/quic-go/h2quic.(*Server).handleRequest
	/home/caddy/go/src/github.com/lucas-clemente/quic-go/h2quic/server.go:202 +0x628

The github/lucas-clemente/quic-go is the library Caddy using to implement QUIC feature.
I will report this problem.

Thank you Nota,

will definetly try that out.

but regarding the Go-Panic: This bug has already been reported and fixed by Marten Seemanns Patch. Link to the issue here.

And Marten Seemanns Patch here.

wow, thanks for the patch!

What you can also do, which is much easier i guess, is to recompile caddy again to gain the updated binary:

copy the binary to your production folder.

thanks, I will try that :grin:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.