Windows - Only one usage of each socket address is normally permitted

1. Caddy version (caddy version):


2. How I run Caddy:

As a Windows service with WinSW using this tutorial: Keep Caddy Running — Caddy Documentation

a. System environment:

Windows 11 Pro x64

b. Command:

caddy start

c. Service/unit/compose file:


d. My complete Caddyfile or JSON config:

:8080 {
	respond "Hello, world!"

3. The problem I’m having:

Caddy does not run.

4. Error messages and/or full log output:

This is the full message I get in the console:

C:\caddy>caddy start
2022/02/08 18:19:27.243 ←[34mINFO←[0m   using adjacent Caddyfile
run: loading initial config: loading new config: starting caddy administration endpoint: listen tcp bind: Only one usage of each socket address (protocol/network address/port) is normally permitted.
start: caddy process exited with error: exit status 1

5. What I already tried:

I tried port 80 too but I didn’t think that would work because my ISP probably has that tied up.

6. Links to relevant resources:

This is telling me you probably already have another instance of Caddy running, bound to port 2019 (the admin API endpoint).

1 Like

I’m an idiot! That was it. Thank you!

This topic was automatically closed after 30 days. New replies are no longer allowed.