Unknown weird domain name in caddy log

1. Caddy version (caddy version):

caddy version
v2.2.1 h1:Q62GWHMtztnvyRU+KPOpw6fNfeCD3SkwH7SfT1Tgt2c=

2. How I run Caddy:

a. System environment:

uname -a
Linux VM-0-7-ubuntu 5.4.0-54-generic #60-Ubuntu SMP Fri Nov 6 10:37:59 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

b. Command:

sudo systemctl start caddy

c. Service/unit/compose file:

Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane.

d. My complete Caddyfile or JSON config:

 cat /etc/systemd/system/caddy.service
# caddy.service
#
# For using Caddy with a config file.
#
# Make sure the ExecStart and ExecReload commands are correct
# for your installation.
#
# See https://caddyserver.com/docs/install for instructions.
#
# WARNING: This service does not use the --resume flag, so if you
# use the API to make changes, they will be overwritten by the
# Caddyfile next time the service is restarted. If you intend to
# use Caddy's API to configure it, add the --resume flag to the
# `caddy run` command or use the caddy-api.service file instead.

[Unit]
Description=Caddy
Documentation=https://caddyserver.com/docs/
After=network.target network-online.target
Requires=network-online.target

[Service]
User=ubuntu
Group=ubuntu
ExecStart=/usr/local/bin/caddy run --environ --config /etc/caddy/Caddyfile
ExecReload=/usr/local/bin/caddy reload --config /etc/caddy/Caddyfile
TimeoutStopSec=5s
LimitNOFILE=1048576
LimitNPROC=512
PrivateTmp=true
ProtectSystem=full
AmbientCapabilities=CAP_NET_BIND_SERVICE

[Install]
WantedBy=multi-user.target

3. The problem I’m having:

4. Error messages and/or full log output:

sudo journalctl --no-pager -u caddy | grep online
Nov 23 23:46:11 VM-0-7-ubuntu caddy[3693569]: {"level":"info","ts":1637682371.5114272,"logger":"http.log.access","msg":"handled request","request":{"remote_addr":"104.243.38.126:55252","proto":"HTTP/1.1","method":"GET","host":"www.yagoal.online","uri":"http://www.yagoal.online/","headers":{"Referer":["http://www.yagoal.online"],"Origin":["http://www.yagoal.online"],"Connection":["close"],"User-Agent":["Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/95.0.4638.54 Safari/537.36"],"Accept":["text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9"],"Accept-Language":["en,zh-CN;q=0.9,zh;q=0.8,is;q=0.7,km;q=0.6,hmn;q=0.5,mn;q=0.4,ja;q=0.3"],"Cache-Control":["no-cache"]}},"common_log":"104.243.38.126 - - [23/Nov/2021:23:46:11 +0800] \"GET http://www.yagoal.online/ HTTP/1.1\" 308 0","duration":0.0000631,"size":0,"status":308,"resp_headers":{"Server":["Caddy"],"Location":["https://www.yagoal.online/"],"Connection":["close"],"Content-Type":[]}}

i never configed yagoal.online domain name in /etc/caddy/Caddyfile, but this line of log found in journalctl -f -u caddy

5. What I already tried:

6. Links to relevant resources:

You’re using a old version of Caddy! Please upgrade to the latest, v2.4.6.

It’s probably a bot that made a request to your server with that Host header set. Likely harmless.