Unable to locate package error

1. Output of caddy version:


2. How I run Caddy:


a. System environment:

Raspbian 11 (Bullseye) on a Raspberry Pi 4

b. Command:

sudo apt install caddy

c. Service/unit/compose file:


d. My complete Caddy config:


3. The problem I’m having:

I’m unable to install the package. I’ve followed the commands from the installation docs, specifically:

sudo apt install -y debian-keyring debian-archive-keyring apt-transport-https
curl -1sLf 'https://dl.cloudsmith.io/public/caddy/stable/gpg.key' | sudo gpg --dearmor -o /usr/share/keyrings/caddy-stable-archive-keyring.gpg
curl -1sLf 'https://dl.cloudsmith.io/public/caddy/stable/debian.deb.txt' | sudo tee /etc/apt/sources.list.d/caddy-stable.list
sudo apt update
sudo apt install caddy

4. Error messages and/or full log output:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package caddy

5. What I already tried:

  • Turning off and on my VPN
  • Checking my /etc/apt/sources.list.d/caddy-stable.list file. It looks like this:
# Source: Caddy
# Site: https://github.com/caddyserver/caddy
# Repository: Caddy / stable
# Description: Fast, multi-platform web server with automatic HTTPS

deb [signed-by=/usr/share/keyrings/caddy-stable-archive-keyring.gpg] https://dl.cloudsmith.io/public/caddy/stable/deb/debian any-version main

deb-src [signed-by=/usr/share/keyrings/caddy-stable-archive-keyring.gpg] https://dl.cloudsmith.io/public/caddy/stable/deb/debian any-version main

6. Links to relevant resources:

I’ve noticed that https://dl.cloudsmith.io/public/caddy/stable/deb/debian is returning 404 right now. Seems likely that’s the problem

This has already been answered here:

This topic was automatically closed after 30 days. New replies are no longer allowed.