Truying To make a internal ca for local domain

1. Caddy version (caddy version):


2. How I run Caddy:

a. System environment:

manjora latesed systemd, and windows 10 20h2 nssm

b. Command:


Paste command here.

truing to setup a local ca for my internal domain i have caddy running on my manjora pc that is for proxing and i am truing to get a cert and setup a local ca for my service

c. Service/unit/compose file:

Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane.

d. My complete Caddyfile or JSON config:

below is the windows caddy
#acme_ca https://caddy.roadrunner/acme/local/directory
http://localhost {
root * c:/usr/share/caddy
import c:\etc\caddy\conf.d*
#END of windows caddy file

Paste config here, replacing this text.
Use `caddy fmt` to make it readable.
DO NOT REDACT anything except credentials.
Make sure the backticks stay on their own lines.

Began of manjora
# Restrict the admin interface to a local unix file socket whose directory
# is restricted to caddy:caddy. By default the TCP socket allows arbitrary
# modification for any process and user that has access to the local
# interface. If admin over TCP is turned on one should make sure
# implications are well understood.
admin “unix//run/caddy/admin.socket”

http:// {
# Set this path to your site’s directory.
root * /usr/share/caddy

    # Enable the static file server.

    # Another common task is to set up a reverse proxy:
    # reverse_proxy localhost:8080

    # Or serve a PHP site through php-fpm:
    # php_fastcgi localhost:9000

    # Refer to the directive documentation for more options.


Import additional caddy config files in /etc/caddy/conf.d/

import /etc/caddy/conf.d/*

End of caddy file manjora

3. The problem I’m having:

4. Error messages and/or full log output:

5. What I already tried:

6. Links to relevant resources:

Please properly fill out the help topic template.

i updated it

This topic was automatically closed after 30 days. New replies are no longer allowed.