TLS Fingerprint

1. Caddy version (caddy version):


2. How I run Caddy:

caddy run

a. System environment:


b. Command:

caddy run

c. Service/unit/compose file:


d. My complete Caddyfile or JSON config:

header /* {
    x-airdb-fingerprint: {http.request.tls.client.fingerprint}

3. The problem I’m having:

The value of x-airdb-fingerprint is null

4. Error messages and/or full log output:

No error

5. What I already tried:

{tls_version} and {tls_cipher} are ok.

{tls_client_fingerprint} and {http.request.tls.client.fingerprint} are null

6. Links to relevant resources:

In my understanding, I think the fingerprint is same with ja3 fingerprint. Am I right?

No, that placeholder is just a sha256 hash of the client certificate, if there is one. There probably wasn’t a client certificate, so it’s null.

JA3 support was requested in this GitHub issue, but it was closed because the request was not clearly explained:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.