Sonarr reverse proxy issues on 2.4.4

1. Caddy version (caddy version):


2. How I run Caddy:

Reverse proxy on a Windows box pointing various subdomains to their internal servers/services.

a. System environment:

Windows 10, Caddy installed as a service.

b. Command:

nssm start caddy

c. Service/unit/compose file:


d. My complete Caddyfile or JSON config:

sonarr.domain.tld {
	encode gzip
	log {
		output file	C:/Caddy/logs/caddy_sonarr.log
		format single_field common_log
	reverse_proxy http://localhost:8989 {     
		header_up X-Real-IP {http.request.remote}
		header_up X-Forwarded-Port {http.request.port}
		header_up X-Forwarded-Proto {http.request.scheme}
		header_up X-Forwarded-Ssl {on}

3. The problem I’m having:

On upgrading to Caddy v2.4.4 and trying to visit my Sonarr install via external hostname, I’m presented with a blank white page in the browser.

I am using form based authentication for Sonarr and the internal server is supposed to redirect to /login?returnUrl=/ when trying to access it unauthenticated. If I browse to this URL extension directly, then I can view the page and login. Browsing to the root sub-domain white screens.

  • If I try when already authenticated to Sonarr, it is fine.
  • If I disable authentication in Sonarr, it is fine.
  • If I revert back to v2.4.3 the problem goes away.
  • As soon as I upgrade to v2.4.4 the login page white screens and doesn’t seem to redirect correctly.

4. Error messages and/or full log output:

According to Caddy logs, the server is providing a blank 303 response:- - - [01/Sep/2021:17:34:01 +0100] "GET /favicon.ico HTTP/2.0" 303 0 - - [01/Sep/2021:17:34:01 +0100] "GET / HTTP/2.0" 303 0

5. What I already tried:

  • I have downgraded to 2.4.3 to resolve the problem.
  • Looked at changelogs for v2.4.4 but it isn’t clear to me if anything I am doing has been deprecated/broken in any way.

6. Links to relevant resources:


You’re likely hitting this regression which has already been fixed on master: Content-Encoding header missing with reverse-proxied chunked response · Issue #4314 · caddyserver/caddy · GitHub

Please try it out if you can!

Thanks @matt, will take a look.

@matt - installed 2.4.5 and seems to have done the trick. Thanks again.


This topic was automatically closed after 30 days. New replies are no longer allowed.