Sonarr and Radarr keep loading on Caddy V2

1. My Caddy version (caddy version):

v2.0.0 h1:pQSaIJGFluFvu8KDGDODV8u4/QRED/OPyIR+MWYYse8=

2. How I run Caddy:

caddy run

a. System environment:

Windows 10

d. My complete Caddyfile or JSON config:, {
  basicauth /movies/* {
    user <verylongencryptedpassword>
  basicauth /series/* {
    user <verylongencryptedpassword>
  reverse_proxy /movies
  reverse_proxy /series
  log stdout

3. The problem I’m having:

Sonarr and Radarr are working on Caddy v1 with websocket and transparant, but it seems to keep loading on Caddy v2.

4. Error messages and/or full log output:

5. What I already tried:

Searched Google, but no Sonarr or Radarr user seems to be on Caddy V2 yet.

6. Links to relevant resources:

I think it’s probably because you’re missing the * on your reverse proxies. In v2, path matchers are exact match, so you need to have the * to tell it to allow stuff after it.

  reverse_proxy /movies*
  reverse_proxy /series*

what’s the difference between /movies* and /movies/*


It’s working, thank you so much :slight_smile:

Good question!

/movies* will match requests like /movies, /moviesabc and /movies/abc.

/movies/* will not match /movies or /moviesabc, but will match /movies/ and /movies/abc.

If it’s an issue for you if /movies* matches /moviesabc, then you can use /movies/* and add a redir directive to ensure that /movies is redirected to /movies/ so that it always has a trailing slash. For example:

redir /movies /movies/ 308

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.