Running caddy command hangs


I am setting up a brand new VPS hosted Caddy server. I am installing Caddy via the script (curl | bash -s personal), and it installs with no issues or errors.

When I run “caddy”, I get an error about running ulimit -n 8192. So I run that command, with no errors. Then I rerun “caddy”, and it just sits there. It displays “Activating privacy features…done; http://:2015” then just sits there. I’ve tried letting it run for upwards of 15 minutes with no movement. I can access the default Caddy hosted homepage in a browser, but why the caddy command always hang? I can try caddy -host, and it’ll go through the same thing and get stuck there too.

Hi @joshmsr, welcome to the Caddy community!

Have a look at Caddy’s tutorial documentation:

As noted on that page, when you run caddy on its own, it will serve the contents of your current working directory over port 2015. The message you received indicates that it’s started up and ready to serve clients and you can test it on the command-line by typing curl http://localhost:2015.

When you’re ready to configure Caddy to serve the sites you want on ports 80 and 443, check out the next page demonstrating the Caddyfile:

Yeah, it’s supposed to hang. If it quit, your sites wouldn’t be accessible anymore.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.