Reverse proxy for Transmission [2]

I would like to use reverse proxy for my transmission server. It’s a bit tricky as I found here:

…I followed this topic, but I am still unable to make it work.

Here is my config:

(gzipconf) {
gzip {
ext *
level 7
min_length 1

(addheader) {
header / {
Strict-Transport-Security "max-age=31536000;"
X-XSS-Protection "1; mode=block"
X-Content-Type-Options "nosniff"
X-Frame-Options "DENY"
Referrer-Policy "strict-origin-when-cross-origin"
} {
        log /var/log/caddy/
        errors /var/log/caddy/errors.log
        import gzipconf
        import addheader
        ipfilter / {
        rule allow
        database /etc/caddy/geolite.mmdb
        country SK HU HR
        import int-auth
        proxy / {
           keepalive 32

I am trying to access on

It was a transmission config error:

In transmission settings.json set rpc-host-whitelist to “*”

After that it should work.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.