Reverse-proxy for Jellyfin Server not working after router reboot

1. Output of caddy version:

v2.5.2 h1:eCJdLyEyAGzuQTa5Mh3gETnYWDClo1LjtQm2q9RNZrs=

2. How I run Caddy:

a. System environment:

Windows 10 x64

b. Command:

caddy reverse-proxy --from encom58.ddns.net --to 127.0.0.1:8096

c. Service/unit/compose file:

N/A

d. My complete Caddy config:

No config, been using the one-line command for the last 8 months

3. The problem I’m having:

Router rebooted, no longer able to connect to Jellyfin server through the reverse-proxy.

4. Error messages and/or full log output:

2022/08/02 07:25:30.613 ←[33mWARN←[0m   admin   admin endpoint disabled
2022/08/02 07:25:30.614 ←[34mINFO←[0m   http    server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS {"server_name": "proxy", "https_port": 443}
2022/08/02 07:25:30.614 ←[34mINFO←[0m   http    enabling automatic HTTP->HTTPS redirects        {"server_name": "proxy"}
2022/08/02 07:25:30.614 ←[34mINFO←[0m   tls.cache.maintenance   started background certificate maintenance      {"cache": "0xc00008abd0"}
2022/08/02 07:25:30.615 ←[34mINFO←[0m   tls     cleaning storage unit   {"description": "FileStorage:C:\\Users\\Jake\\AppData\\Roaming\\Caddy"}
2022/08/02 07:25:30.617 ←[34mINFO←[0m   http    enabling automatic TLS certificate management   {"domains": ["encom58.ddns.net"]}
2022/08/02 07:25:30.623 ←[34mINFO←[0m   tls     finished cleaning storage units
2022/08/02 07:25:30.630 ←[34mINFO←[0m   autosaved config (load with --resume flag)      {"file": "C:\\Users\\Jake\\AppData\\Roaming\\Caddy\\autosave.json"}
Caddy proxying https://encom58.ddns.net -> 127.0.0.1:8096

5. What I already tried:

I checked to see if the router reboot removed the port forwarding settings for ports 80 and 443, but both ports are still being forwarded. I then checked to see if the local IP for the server changed, but my router’s control panel shows that the server is at the same local IP, and further I’m able to connect to the Jellyfin server on LAN by using that local IP. I checked if my DDNS was pointing at my correct external IP, and it is; I also checked that my ISP was not blocking ports 80 or 443, and I confirmed they are open on my external IP. As such, I have confirmed the problem is not with Jellyfin, my DDNS, or my router settings. I have followed all steps listed here without being able to solve the problem.

6. Links to relevant resources:

Answered on Discord, ISP was in fact blocking port 443, but not port 80.

3 Likes