Return 500 when download http.awslambda plugin

I’m downloading caddy with http.awslambda plugin
I ran

curl | bash -s personal http.awslambda

and the output:

# curl | bash -s personal http.awslambda                                                                                                                                                                                                                                           19-09-25 - 17:21:38
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  7380  100  7380    0     0   7838      0 --:--:-- --:--:-- --:--:--  7834
Downloading Caddy for linux/amd64 (personal license)...
curl: (22) The requested URL returned error: 500 Internal Server Error
Aborted, error 22 in command: curl -fsSL "$caddy_url" -u "$CADDY_ACCOUNT_ID:$CADDY_API_KEY" -o "$dl"

I found it was actually requesting :

curl -fsSL '' -u : -o /tmp/caddy_linux_amd64_custom.tar.gz

and the http response is:

provisioning build environment: go mod init: exit status 1

with status code 500

it seems server encountered some error.

could anybody help me ?

Do you get the error downloading with any plugins or just http.awslambda?

Try again; the build server ran out of disk space (Go module cache) so I cleared it for now, and downloads are working again. If you still get errors, it’s probably a bug in the plugin.

1 Like

Problem solved!

thanks for your grate help!

Thanks, @Matt helped to solve the problem

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.