Radarr/sonarr etc.. without base url

1. Caddy version (caddy version):

2.1.1 docker builder with webdav, http.filter and cloudflare dns module

2. How I run Caddy:

Running using docker/docker-compose, from a Caddy builder image.

d. My complete Caddyfile or JSON config:

:80 {

     handle_path /radarr/* {

3. The problem I’m having:

I’ve tried a lot of combinations, but all I get is a blank page that says "Radarr Ver. "

I’d like to avoid a “base url” for radarr and other apps, i was using letsencrypt with the default configuration provided before.

no problem with subdomain but i prefer subfolder for my new config

radarr.domain.com {

There’s not enough information here. What exactly is the problem? Do you have any logs to show the issue?

Generally, I recommend using subdomains because it’s cleaner. If you need local access, you can do something like radarr.domain.com, :8081 { to listen on another port for local access.

But if you must use a subpath instead, then you need to configure a UrlBase in Radarr I think:

Sounds like a chronic case of the subfolder problem.

You can’t put your app in a subfolder without setting the base URL. The base URL must match the subfolder. This is required for asset links to line up. Explained further in this wiki post:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.