QUIC is not supported

1. Caddy version:

2.6.3 (via docker)

2. How I installed, and run Caddy:


a. System environment:

docker on Ubuntu 22.04

b. Command:

docker run -p 80:80 -p 443:443 -p 443:443/udp -v /home/ubuntu/caddy/Caddyfile:/etc/caddy/Caddyfile -v caddy_data:/data caddy:2.6.3

c. My complete Caddy config:

http3://caddy-qa.xyz.com {
     tls abcd@efgh.com
     respond "It workss!"

3. The problem I’m having:

Well, the http3 flow works, but it renders error that QUIC is not supported.
Something like below comes when I do http3 check

Attempted 4 connection(s).
Received packets for 4 connection(s).
Successful handshake for 2 connection(s).

4. What I already tried:

I have tried a bunch of changes in the Caddyfile, with server blocks, protocol blocks etc.

PS. all ports are open, for both UDP and TCP,

How are you testing it?

Caddy does not support old QUIC versions.

hello,I also encountered this problem.

I use this website for testing.

QUIC is not supported
HTTP/3 is supported

But I see other people’s caddy server website, but it supports QUIC.


my.website {
  root * /usr/local/ServerStatus/web
  encode gzip quic

That website is by LiteSpeed and only checks old versions of QUIC. New versions of Caddy only support http3. Modern browsers only support http3 at this point.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.