Problems with git plugin

(Andrine) #1

I am trying to setup the git plugin but I get an error. I am following this youtube tutorial, but after 2:44 I get

root@ubuntu~# caddy
Activating privacy features… done.
From https://github.com/Name/MyRepoAame

On my server the structure is:
I have a directory called myreponame with an index.html and the Caddyfile. The Caddyfile contains:

https://myWebPage.com

git github.com/mygithubaccount/myrepo

root myreponame

When I type pwd I get /root, so I have tested to change the Caddyfile to:

https://myWebPage.com

git github.com/mygithubaccount/myrepo

root /root/myreponame

but I can the same error: 2019/01/18 18:20:18 listen tcp :443: bind: address already in use

Just shout out if I need to explain any further. I appreciate the help I get.

(Andrine) #2

When I test with $ dig myhomepage.com I get

QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

(Matthew Fay) #3

This error means that Caddy tried to bind to port 443, but failed (because some other process is already using that port).

You can check which program it is with the command: netstat -tulpn | grep 443

(Andrine) #4

Does not really tell me to much @Whitestrake

(Matthew Fay) #5

Looks like Caddy is already running in the background (with the process ID 31069). You won’t be able to run two Caddies on the same ports, so you’ll want to take down that one before starting it up again.

If it’s not running as a service, you can run the command kill -SIGTERM 31069 to have the system signal the other Caddy to shut down gracefully.

(Andrine) #6

You know everything, thanks

(Andrine) #7

And now I have a problem with webhooks…

This is now my Caddyfile:

https://MyUrl.com

git github.com/GithubName/RepoName . {
hook /_webhook some-keys
}

root DirectoryWithFiles

Here is screenshot from Github:

And I get Last delivery was not succesfull

“could not connect to server”

(Matthew Fay) #8

Is the server running?

Can you access that URL in your browser?

1 Like
(Andrine) #9

Works now. Haha, that was a blunder. Thanks!

1 Like
(system) closed #10

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.