Problem with wetty setup

1. Caddy version (caddy version):


2. How I run Caddy:

a. System environment:

docker 20.10.5 (API: 1.41) on linux x86_64 Ubuntu 16.04.7 LTS

b. Command:

caddy run --config /etc/caddy/Caddyfile --adapter caddyfile

d. My complete Caddyfile or JSON config: {
reverse_proxy localhost:32400 {
encode gzip
header {
Strict-Transport-Security max-age=31536000;
X-Content-Type-Options nosniff
X-Frame-Options DENY
Referrer-Policy no-referrer-when-downgrade
X-XSS-Protection 1
} {
reverse_proxy /wetty* localhost:3000

3. The problem I’m having:

When I open, I am successfully being directed to localhost:3000. But after the login on wetty (GitHub - butlerx/wetty: Terminal in browser over http/https. (Ajaxterm/Anyterm alternative, but much better)), a “transport close” error appears.

Caddy shows a “connection refused” error in the log.

4. Error messages and/or full log output:

{"level":"error","ts":1617220147.4595969,"logger":"http.log.error","msg":"dial tcp connect: connection refused","request":{"remote_addr":"","proto":"HTTP/2.0","method":"GET","host":"","uri":"/wetty/","headers":{"Accept-Encoding":["gzip, deflate, br"],"Sec-Ch-Ua":["\"Google Chrome\";v=\"89\", \"Chromium\";v=\"89\", \";Not A Brand\";v=\"99\""],"Accept":["*/*"],"User-Agent":["Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.114 Safari/537.36"],"Sec-Fetch-Site":["same-origin"],"Sec-Fetch-Dest":["empty"],"Sec-Ch-Ua-Mobile":["?0"],"Sec-Fetch-Mode":["cors"],"Referer":[""],"Accept-Language":["de-AT,de-DE;q=0.9,de;q=0.8,en-US;q=0.7,en;q=0.6"],"Cookie":["_ga=GA1.3.2027344051.1579269618; sort_direction=descending; sort_method=percent_completed; filter=all; ...

5. What I already tried:

Not much, don’t know where to start.

6. Links to relevant resources:

I figured out this problem was apparently related to wetty itself (bash command -p not found · Issue #315 · butlerx/wetty · GitHub).

The Caddyfile above works.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.