Plugin cant download error

https://caddyserver.com/download

try to download caddy with plugin:
tls.dns.cloudflare;;
get error, how can I install cloudflare plugin???

Error:

Oops. Maybe one of the plugins is temporarily broken. Try adjusting which plugins you’ve selected, or download Caddy from GitHub without any plugins (it will always work!).;;;

Pinging @matt - this might be a question for him, I know the build server had one issue recently that required his attention.

Sigh, it appears to be an error related to Go modules:

2019/10/01 00:03:15 exec [/tmp/buildenv_10-01-0003.051978053/main] /usr/local/bin/go mod vendor
go: finding github.com/payintech/caddy-datadog latest
go: github.com/caddyserver/dnsproviders@v0.3.0 requires
	github.com/h2non/gock@v0.0.0-00010101000000-000000000000: invalid version: unknown revision 000000000000

2019/10/01 00:03:16 build failed: HTTP 400: provisioning build environment: go mod vendor: exit status 1

I don’t have time to fix it right now :frowning: But will try to get around to it soon. In the meantime, you will have to build from source yourself. There are instructions on the readme, including how to add plugins. If you encounter the same error while doing that, then that would be very good to know!

1 Like

Would this problem account for the following as well:

root@nextcloud:~ # curl https://getcaddy.com | bash -s personal tls.dns.cloudflare
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  7380  100  7380    0     0  21206      0 --:--:-- --:--:-- --:--:-- 21146
Downloading Caddy for freebsd/amd64 (personal license)...
curl: (22) The requested URL returned error: 500 
Aborted, error 22 in command: curl -fsSL "$caddy_url" -u "$CADDY_ACCOUNT_ID:$CADDY_API_KEY" -o "$dl"
root@nextcloud:~ # 

?

Could be related, did you get that error today?

I saw that error at the time I posted, and it’s still present now. If I remove the Cloudflare plugin, it works just fine.

Edit: When I try it now (1330 EDT 2 Oct) with the Cloudflare plugin, it seems to be working again.

Issue with most of the DNS plugins on the build server was fixed today.

1 Like

Tried building from source, including the http.reauth plugin. I’m an extreme beginner, so it’s totally possible I messed up somewhere, but I was getting an error when building. I followed the instructions in the read-me, and created a go file with the following contents.

package main

import (
github.com/caddyserver/caddy/caddy/caddymain

// plug in plugins here, for example:
 _ "github.com/freman/caddy-reauth"

)

func main() {
// optional: disable telemetry
// caddymain.EnableTelemetry = false
caddymain.Run()
}


So, I think I have the correct plugin path but maybe that’s my problem? Anyway, after giving the “go install” command, it runs through and downloads packages, extracts them, and grabs a whole bunch more until I get this error and it stops.

build caddy: cannot load github.com/lucas-clemente/quic-go/h2quic: module github.com/lucas-clemente/quic-go@latest (v0.12.0) found, but does not contain package github.com/lucas-clemente/quic-go/h2quic

So, that’s where I’m at. Maybe it’s just my beginner skills having made a mistake somewhere, or maybe there’s something else broken?

Would anyone more experienced than I be willing to build this from source for Linux 64bit, with the http.reauth plugin? I’m not having any luck. I’d be more than happy to contribute to any tip jar you might have as a thanks.