Please Help. I think this is an easy fix


(James Buse) #1

Hi everyone,

I am total noob here with proxying.

I am trying to get a domain I have to point to the ombi app.
So example.com to localhost:5000

I have dns in cloudfare setup correctly.

I have also confirmed ports 80 & 443 are open.

When I startup caddy i run an admin cmd session and then type C:\Caddy\caddy.exe -host example. com

It says its serving http & https on ports 443 & 80

However when I try to go to example.com I just get 404 Not Found

Here is my caddy file:

example.com, www.example.com {
gzip
proxy / 127.0.0.1:5000 {
transparent
}

}

Please Help! Thanks


(James Buse) #2

On the startup command please ignore the space between . com. This site wouldnt let me post without adding that space because too many links for new user


(DovahMerith) #3

In your caddy file, you will need to explicitly state where the root directory of your website is, and if it uses html or php

For example, try adding this to your caddy file

index index.html
root C:\Path\to\Website\files

Also, trying using caddy.exe -conf C:\path\to\caddyfile instead of host


(James Buse) #4

So Ombi is an application tied into plex that runs its own webserver. If i go to mydomain.com:5000 I can reach it from outside my network. However my goal is to get it so I just have to go to mydomain.com and reach it.


(Matthew Fay) #5

You just need to ensure that Caddy is reading from the Caddyfile you want it to.

Ditch the -host flag and use -conf instead; Caddy should figure out the hostname from your Caddyfile.

C:\Caddy\caddy.exe -conf C:\path\to\Caddyfile


P.S.: mydomain.com is owned by a registrar and is currently hosted by an Apache server. example.com is the right domain to use for demonstration or example purposes.


(James Buse) #6

That worked! Thanks so much