Organizr ServerAuth with V2

Hi Guys!

I’m trying to set up Organizr for authentication using the instructions here. I’ve added the cadd2-reauth plugin but I’m not sure how to convert the given block for used in my Caddyfile (shown below):

{$DOMAIN_NAME} {
    reverse_proxy organizr:80
}

ombi.{$DOMAIN_NAME} {
    reverse_proxy ombi:3579
}

sonarr.{$DOMAIN_NAME} {
    reverse_proxy sonarr:8989

}

reauth {
  path sonarr.{$DOMAIN_NAME}
  failure redirect target=https://xkcd.com/
  upstream url=https://{$DOMAIN_NAME}/api/?v1/auth&group+4,cookies=true
}

jellyfin.{$DOMAIN_NAME} {
    reverse_proxy jellyfin:8096
}

The error I receive from ‘docker logs caddy’ is:

{"level":"info","ts":1595863624.4425788,"msg":"using provided configuration","config_file":"/etc/caddy/Caddyfile","config_adapter":"caddyfile"}
run: adapting config using caddyfile: /etc/caddy/Caddyfile:27: unrecognized directive: path

Let me know if there’s any other information I should post.

Thanks in advance!
Josh

The example in the Organizr docs is for Caddy v1, with the https://github.com/freman/caddy-reauth plugin.

Caddy v2 is a complete rewrite from the ground up, so v1 plugins are not directly compatible. It looks like there’s a work-in-progress port of the plugin to v2 here https://github.com/freman/caddy2-reauth but it doesn’t seem ready yet.

Yeah. I ran across that plugin and added it to my Dockerfile. I just haven’t been able to figure out how to use it yet.

I’ve tried putting the reauth block inside and outside of the site block with similar results.

I think the v2 version of that plugin doesn’t yet have Caddyfile support. I think you would inquire on that repo as to the status.