Odoo Website editor hangs with reverse proxy

1. The problem I’m having:

I have Odoo installed (through docker compose) that runs an e-commerce website. I can reach Odoo just fine through my domain with Caddy setup as the reverse proxy. The problem is when I try to use the e-commerce website editor, something isn’t getting passed through and it just hangs.

2. Error messages and/or full log output:

It just hangs with a rotating circle.   As if it's waiting for something.   There's no apparent errors, and I don't know where I would look to find any. 

3. Caddy version:


4. How I installed and ran Caddy:

a. System environment:

Caddy is installed with systemd service on a virtual machine Ubuntu Server 20.4, with nothing else running on it.

b. Command:

The problematic prefix looks like this-


d. My complete Caddy config:

I omitted the TLS settings because Odoo does not run in HTTPS. I have tried caddy with and without, and this is the way it works. The only part that doesn’t work is with the editor, that redirects to /web#action=178&cids=1&menu_id=116

1domain.com {
reverse_proxy #{
#transport http {

You’ll need to ask for help from Odoo devs. We can’t help debug application problems.

Check Caddy’s logs, turn on the debug global option to see more detailed logs. Show us what those look like, as instructed by the help topic template.

Thanks for the quick reply.

It appears that I need to set Caddy to “upgrade-insecure-requests”, but I am not sure how.

Also, I’m having trouble getting the log to write. It created the file, but I get

cat: my1domain.log: Permission denied

I tried to chown /var/logs/caddy but it didn’t help

Caddy automatically redirects HTTP requests to HTTPS.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.