Nextcloud php errors


(xincun) #1

winserver+caddy0.10.12+mariadb10.2.14+php7.2.4

https://github.com/caddyserver/examples/tree/master/winphp
https://github.com/caddyserver/examples/tree/master/nextcloud

:80 { 
on startup C:\Users\vwin7_x64\Desktop\php7\php-cgi.exe -b 6545  &
fastcgi / 127.0.0.1:6545 php 

root C:\Users\vwin7_x64\Desktop\web\website\nextcloud
log stdout
errors stdout

# checks for images
    rewrite {
        ext .svg .gif .png .html .ttf .woff .ico .jpg .jpeg
	r ^/index.php/(.+)$
	to /{1} /index.php?{1}
}

rewrite {
	r ^/index.php/.*$
	to /index.php?{query}
}

# client support (e.g. os x calendar / contacts)
redir /.well-known/carddav /remote.php/carddav 301
redir /.well-known/caldav /remote.php/caldav 301

# remove trailing / as it causes errors with php-fpm
rewrite {
	r ^/remote.php/(webdav|caldav|carddav|dav)(\/?)$
	to /remote.php/{1}
}

rewrite {
	r ^/remote.php/(webdav|caldav|carddav|dav)/(.+?)(\/?)$
	to /remote.php/{1}/{2}
}

rewrite {
	r ^/public.php/(dav|webdav|caldav|carddav)(\/?)$
	to /public.php/{1}
}

rewrite {
	r ^/public.php/(dav|webdav|caldav|carddav)/(.+)(\/?)$
	to /public.php/{1}/{2}
}

# .htaccess / data / config / ... shouldn't be accessible from outside
status 403 {
	/.htacces
	/data
	/config
	/db_structure
	/.xml
	/README
}

header / Strict-Transport-Security "max-age=31536000;"

}   



Php seems to be running correctly.


(Matthew Fay) #2

Looks like the PHP script generated an error while trying to access this file:

You might want to check the PHP user account has the required file permissions.


(xincun) #3

Snipaste_2018-04-11_15-38-10

MariaDB database server are running.
All moved to the D drive to evade folder permissions.

:80 { 
on startup D:\php7\php-cgi.exe -b 6545  &
fastcgi / 127.0.0.1:6545 php 

root D:\web\website\nextcloud
log stdout
errors stdout

………………………………

}

(Matthew Fay) #4

That error typically means either there’s no service listening on that port (PHP possibly didn’t start correctly?) or there’s a firewall in the way (does Windows firewall uncommon ports from itself?).


(xincun) #5

The strange thing is that I never started successfully php again. Fastcgi syntax error? Turn off the firewall is not useful. Caddy needs special plug-ins?


(Matthew Fay) #6

Caddy itself seems to be configured correctly and it’s trying to contact 127.0.0.1:6545, but nothing is listening there.

Possibly PHP-CGI is not working correctly.


(xincun) #7

Used caddy 10.10 solved the problem of php startup. Back to the first question. Full control by adding everyone also prompts errors.

\nextcloud\lib\private\Log\File.php on line 136

if ((fileperms(self::$logFile) & 0777) != 0640) { 
@chmod(self::$logFile, 0640);
}