Nextcloud: Conversion of to Caddyfile

1. The ~problem~ question I’m having:

With the help of the web I translated my nextcloud nginx config to a Caddyfile and I want help verifying that the Caddyfile will result in the same service as the nginx config and where it will differ, if so.
Since the nextcloud is important for my family, I don’t want to just try it.

2. Error messages and/or full log output:

Caddy is not running, so no logs.

3. Caddy version:

v2.7.6 h1:w0NymbG2m9PcvKWsrXO6EEkY9Ru4FJK8uQbYcev1p3A=

4. How I installed and ran Caddy:

a. System environment:

cat /etc/os-release
PRETTY_NAME="Ubuntu 22.04.4 LTS"
VERSION="22.04.4 LTS (Jammy Jellyfish)"

Caddy is installed from
Stable Caddy will be installed according to Install — Caddy Documentation

b. Command:

systemd service provided by caddy repo
User in systemd will likely be changed to www-data

c. Service/unit/compose file:

not installed yet

d. My complete Caddy config:

        log {
                format console
        email srv-nextcloud@lencat.internal
        acme_ca https://step.lencat.internal/acme/lencat/directory

        servers :443 {
                name https

        servers :80 {
                name http

cloud.lencat.internal {
        header {
                Strict-Transport-Security         "max-age=63072000; includeSubDomains"
				Referrer-Policy                   "no-referrer"
				X-Content-Type-Options            "nosniff"
				X-Frame-Options                   "SAMEORIGIN"
				X-Permitted-Cross-Domain-Policies "none"
				X-Robots-Tag                      "noindex, nofollow, nocache"
				X-XSS-Protection                  "1; mode=block"

        @static {
                path *.ico *.css *.js *.gif *.webp *.avif *.jpg *.jpeg *.png *.svg *.woff *.woff2
        header @static Cache-Control "public, max-age=15778463"

        @immutable {
                path *.ico *.css *.js *.gif *.webp *.avif *.jpg *.jpeg *.png *.svg *.woff *.woff2
                query v=*
        header @immutable Cache-Control "public, max-age=15778463, immutable"

        root * /var/www/cloud.lencat.internal

        request_body {
                max_size 512MB

        @forbidden {
                path /data/*
                path /config/*
                path /db_structure
                path /README
                path /3rdparty/*
                path /lib/*
                path /templates/*
                path /occ
                path /build/*
                path /tests/*
                path /.*
                path /autotest/*
                path /issue/*
                path /indie/*
                path /console.php
                path /AUTHORS
                path /COPYING
        respond @forbidden 404

        @MSDav {
                header User-Agent "DavClnt*"
        redir @MSDav /remote.php/webdav/?{query} 302

        redir /.well-known/carddav /remote.php/dav 301
        redir /.well-known/caldav /remote.php/dav 301
		# TODO: Are acme-challenge and pki-validation handled by caddy?
        redir /.well-known/* /index.php{uri} 301
        redir /remote /remote.php{uri} 301

        php_fastcgi unix//run/php/php8.1-fpm.sock

e. My running nginx config:

upstream php-handler {
    server unix:/run/php/php8.1-fpm.sock;

# Set the `immutable` cache control options only for assets with a cache busting `v` argument
map $arg_v $asset_immutable {
    "" "";
    default ", immutable";

server {
    listen 80;
    listen [::]:80;
    server_name cloud.lencat.internal;

    # Prevent nginx HTTP Server Detection
    server_tokens off;

    # Enforce HTTPS
    return 301 https://$server_name$request_uri;

server {
    listen 443      ssl http2;
    listen [::]:443 ssl http2;
    server_name cloud.lencat.internal;

    # Path to the root of your installation
    root /var/www/cloud.lencat.internal;

    # Use Mozilla's guidelines for SSL/TLS settings
    ssl_certificate     /etc/ssl/nginx/cloud.lencat.internal.crt;
    ssl_certificate_key /etc/ssl/nginx/cloud.lencat.internal.key;

    ssl_session_timeout 1d;
    ssl_session_cache shared:MozSSL:10m;  # about 40000 sessions
    ssl_session_tickets off;

    # modern configuration
    ssl_protocols TLSv1.3;
    ssl_prefer_server_ciphers off;

    # Prevent nginx HTTP Server Detection
    server_tokens off;

    # HSTS settings
    # WARNING: Only add the preload option once you read about
    # the consequences in This option
    # will add the domain to a hardcoded list that is shipped
    # in all major browsers and getting removed from this list
    # could take several months.
    add_header Strict-Transport-Security "max-age=15768000; includeSubDomains" always;

    # set max upload size and increase upload timeout:
    client_max_body_size 512M;
    client_body_timeout 300s;
    fastcgi_buffers 64 4K;

    # Enable gzip but do not remove ETag headers
    gzip on;
    gzip_vary on;
    gzip_comp_level 4;
    gzip_min_length 256;
    gzip_proxied expired no-cache no-store private no_last_modified no_etag auth;
    gzip_types application/atom+xml text/javascript application/javascript application/json application/ld+json application/manifest+json application/rss+xml application/vnd.geo+json application/ application/wasm application/x-font-ttf application/x-web-app-manifest+json application/xhtml+xml application/xml font/opentype image/bmp image/svg+xml image/x-icon text/cache-manifest text/css text/plain text/vcard text/vnd.rim.location.xloc text/vtt text/x-component text/x-cross-domain-policy;

    # Pagespeed is not supported by Nextcloud, so if your server is built
    # with the `ngx_pagespeed` module, uncomment this line to disable it.
    #pagespeed off;

    # The settings allows you to optimize the HTTP2 bandwidth.
    # See
    # for tuning hints
    client_body_buffer_size 512k;

    # HTTP response headers borrowed from Nextcloud `.htaccess`
    add_header Referrer-Policy                   "no-referrer"                always;
    add_header X-Content-Type-Options            "nosniff"                    always;
    add_header X-Frame-Options                   "SAMEORIGIN"                 always;
    add_header X-Permitted-Cross-Domain-Policies "none"                       always;
    add_header X-Robots-Tag                      "noindex, nofollow, nocache" always;
    add_header X-XSS-Protection                  "1; mode=block"              always;

    # Remove X-Powered-By, which is an information leak
    fastcgi_hide_header X-Powered-By;

    # Set .mjs and .wasm MIME types
    # Either include it in the default mime.types list
    # and include that list explicitly or add the file extension
    # only for Nextcloud like below:
    include mime.types;
    types {
        text/javascript mjs;
		application/wasm wasm;

    # Specify how to handle directories -- specifying `/index.php$request_uri`
    # here as the fallback means that Nginx always exhibits the desired behaviour
    # when a client requests a path that corresponds to a directory that exists
    # on the server. In particular, if that directory contains an index.php file,
    # that file is correctly served; if it doesn't, then the request is passed to
    # the front-end controller. This consistent behaviour means that we don't need
    # to specify custom rules for certain paths (e.g. images and other assets,
    # `/updater`, `/ocs-provider`), and thus
    # `try_files $uri $uri/ /index.php$request_uri`
    # always provides the desired behaviour.
    index index.php index.html /index.php$request_uri;

    # Rule borrowed from `.htaccess` to handle Microsoft DAV clients
    location = / {
        if ( $http_user_agent ~ ^DavClnt ) {
            return 302 /remote.php/webdav/$is_args$args;

    location = /robots.txt {
        allow all;
        log_not_found off;
        access_log off;

    # Make a regex exception for `/.well-known` so that clients can still
    # access it despite the existence of the regex rule
    # `location ~ /(\.|autotest|...)` which would otherwise handle requests
    # for `/.well-known`.
    location ^~ /.well-known {
        # The rules in this block are an adaptation of the rules
        # in `.htaccess` that concern `/.well-known`.

        location = /.well-known/carddav { return 301 /remote.php/dav/; }
        location = /.well-known/caldav  { return 301 /remote.php/dav/; }

        location /.well-known/acme-challenge    { try_files $uri $uri/ =404; }
        location /.well-known/pki-validation    { try_files $uri $uri/ =404; }

        # Let Nextcloud's API for `/.well-known` URIs handle all other
        # requests by passing them to the front-end controller.
        return 301 /index.php$request_uri;

    # Rules borrowed from `.htaccess` to hide certain paths from clients
    location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)(?:$|/)  { return 404; }
    location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console)                { return 404; }

    # Ensure this block, which passes PHP files to the PHP process, is above the blocks
    # which handle static assets (as seen below). If this block is not declared first,
    # then Nginx will encounter an infinite rewriting loop when it prepends `/index.php`
    # to the URI, resulting in a HTTP 500 error response.
    location ~ \.php(?:$|/) {
        # Required for legacy support
        rewrite ^/(?!index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|ocs-provider\/.+|.+\/richdocumentscode(_arm64)?\/proxy) /index.php$request_uri;

        fastcgi_split_path_info ^(.+?\.php)(/.*)$;
        set $path_info $fastcgi_path_info;

        try_files $fastcgi_script_name =404;

        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param PATH_INFO $path_info;
        fastcgi_param HTTPS on;

        fastcgi_param modHeadersAvailable true;         # Avoid sending the security headers twice
        fastcgi_param front_controller_active true;     # Enable pretty urls
        fastcgi_pass php-handler;

        fastcgi_intercept_errors on;
        fastcgi_request_buffering off;

        fastcgi_max_temp_file_size 0;

    # Serve static files
    location ~ \.(?:css|js|mjs|svg|gif|png|jpg|ico|wasm|tflite|map|ogg|flac)$ {
        try_files $uri /index.php$request_uri;
        # HTTP response headers borrowed from Nextcloud `.htaccess`
        add_header Cache-Control                     "public, max-age=15778463$asset_immutable";
        add_header Referrer-Policy                   "no-referrer"                 always;
        add_header X-Content-Type-Options            "nosniff"                     always;
        add_header X-Frame-Options                   "SAMEORIGIN"                  always;
        add_header X-Permitted-Cross-Domain-Policies "none"                        always;
        add_header X-Robots-Tag                      "noindex, nofollow, no-cache" always;
        add_header X-XSS-Protection                  "1; mode=block"               always;
        access_log off;     # Optional: Don't log access to assets

    location ~ \.woff2?$ {
        try_files $uri /index.php$request_uri;
        expires 7d;         # Cache-Control policy borrowed from `.htaccess`
        access_log off;     # Optional: Don't log access to assets

    # Rule borrowed from `.htaccess`
    location /remote {
        return 301 /remote.php$request_uri;

    location / {
        try_files $uri $uri/ /index.php$request_uri;

5. Links to relevant resources:

Default nextcloud nginx: NGINX configuration — Nextcloud latest Administration Manual latest documentation

Looks fine to me.