Need help with multiple domains & SSL on TrueNAS Jail

1. Caddy version (caddy version): 2.5.0

2. How I run Caddy:

Running Caddy on a TrueNAS (FreeBSD) system running os version 13.0-RELEASE. Jail is running FeeBSD 13.1-RC6. Jail has a dedicated IP address on my internal network, and is in the DMZ on my router for that IP.

I have two domains with Dynamic DNS entries pointing to my router:

Domain #1 => domain, works fine when browsed to.  I am looking to move away from this, and use #2 below.

Domain #2 => Namecheap domain, resolves to the same IP, but I get an SSL error when I try to browse to http(s)://

a. System environment:

TrueNAS-13.0-RELEASE host, Caddy is in a FreeBSD 13.1-RC6 jail, created by a script from DanB35.

b. Command:

(No commands used, caddy created by script)

c. Service/unit/compose file:


d. My complete Caddyfile or JSON config:

}, {
  root * /usr/local/www/html

3. The problem I’m having:

Browsing to #1 works as intended.

Browsing to #2 results in a SSL Protocol error.

4. Error messages and/or full log output:

root@caddy:~ # curl -v
*   Trying
* Connected to ( port 80 (#0)
> GET / HTTP/1.1
> Host:
> User-Agent: curl/7.83.1
> Accept: */*
* Mark bundle as not supporting multiuse
< HTTP/1.1 308 Permanent Redirect
< Connection: close
< Location:
< Server: Caddy
< Date: Sat, 21 May 2022 20:55:01 GMT
< Content-Length: 0
* Closing connection 0

5. What I already tried:

  • Recreated Caddy jail from scratch
  • Recreated Caddyfile from scratch
  • Pinged & browsed both sites from internally and externally, ensured they had matching IP addresses

6. Links to relevant resources:

Caddy Jail (Server) created using: GitHub - danb35/freenas-iocage-caddy: Script to install Caddy V2 in a FreeNAS jail

Hosted URLs:

Thank you for your guidance and help!

As soon as I posted this, I thought of something, and added to my Caddyfile. That fixed the issue. This should be resolved, for now.

Sometimes, all it takes is asking the question “out loud” to figure out the answer on your own…


This topic was automatically closed after 30 days. New replies are no longer allowed.