Need help running server on port 80

Hey guys. I’ve been running Caddy happily for a few years now. Thanks for the great product!

In full transparency, I know enough about this stuff to make me dangerous so I could use a little hand holding. Today I’m trying to set up an ‘emulated hue server’ for my Home Assistant install on my OpenMediaVault server (x86 based). The purpose is to allow for Amazon Alexa devices to see some of my home automation devices and interact with them. This server addon runs on port 80. I’m getting an error when trying to start it saying that port 80 is already in use. When I go to I get the ‘404 site not served on this interface’ .

I thought I could outsmart things and ran on port 8686 and tried forwarding using: {
    proxy / localhost:8686 {

This appeared to work and I could see the server providing with information but sadly my Alexa didn’t see the emulated hue devices.

I tried this to see if I had anything running on port 80:

root@omv:~# iptables -S | grep "port 80 "
-A DOCKER -d ! -i docker0 -o docker0 -p tcp -m tcp --dport 80 -j ACCEPT
-A DOCKER -d ! -i docker0 -o docker0 -p tcp -m tcp --dport 80 -j ACCEPT

I looked these up in portainer and one is organizr docker port mapping 80->8895 and the other is pihole docker mapping 80->1010 .

Can someone help me figure out what is using port 80 and how I might clear it so I can run the emulated hue server? What a mess! Any help is most appreciated.

I changed my launch command to this:

/usr/local/bin/caddy -conf /sharedfolders/appdata/Caddy/Caddyfile -http-port 95

Now I’m able to start a service on port 80. Sadly I’m still not able to see my devices with Alexa but that may be a whole other issue.

This topic was automatically closed after 30 days. New replies are no longer allowed.