My package has an error showing on the download page

1. The problem I’m having:

Hi, I just claimed my package, but when I checked the download page, I saw an error like in the image below.

I’m not sure what’s wrong, but it seems to be fetching an old version of the package (I know that the initial release didn’t have the correct doc and JSON structure for the modules, but I fixed it in the latest version: v1.0.3). See godoc page.

It might be helpful if the ‘Your packages’ page showed which version of the package Caddy fetched.

2. Error messages and/or full log output:

This package does not add any modules to the JSON config structure. Either it is another kind of plugin (such as a config adapter) or this listing is in error.

3. Caddy version:

4. How I installed and ran Caddy:

a. System environment:

b. Command:

N/A

c. Service/unit/compose file:

N/A

d. My complete Caddy config:

N/A

5. Links to relevant resources:

I see on GitHub your package needs cgo. We don’t support cgo. It’s not possible to cross-compile cgo packages efficiently.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.