Module installation with Unraid

1. Caddy version (caddy version):

2.2.1 builder

2. How I run Caddy:

a. System environment:

Unraid Version 6.9.0-rc1

3. The problem I’m having:

My question is: How to get this command running with Unraid?
xcaddy build --with

I would like to deploy Caddy with modules via Unraid. I’ve read the official docker page which describes how to use xcaddy including the --with argument, but I don’t know how to run the xcaddy commands when deploying via Unraid.

Installing the module afterwards would be fine for me. But how is this possible?

4. Error messages and/or full log output:

Container starting successfully when deployed without modules (repository caddy:alpine)
Container not starting when deployed with builder (repository caddy:builder-alpine)

5. What I already tried:

Unraid provided a GUI to deploy docker containers, with preset arguments. Arguments for modules are missing, since the values get translated to a normal docker run command.

Since modules can’t be added via docker run variables (please add this :slight_smile:), xcaddy can’t be used when a container is deployed. It also can’t be run, since deploying the container from the build repository doesn’t work.

6. Links to relevant resources:

That’s impossible. Caddy needs to be compiled before being run. That’s what the docker build step from a Dockerfile is for.

Like I’ve said on Discord, this is an unraid question rather than a Caddy question. All the relevant information for Docker + Caddy are in the docs on Docker Hub. You need to find out how to get unraid to build docker images from Dockerfiles.


it seems that adding modules to Caddy on an Unraid installation does not seem possible with Unraid, because xcaddy can’t be used their. I know how to deploy docker containers with Unraid and joined the discord, everyone their told me it doesn’t seem possible.

My feature suggestion is following, making modules with automatic updates available for everyone:

Like I said, that’s not possible. You seem to have a fundamental misunderstanding of how Docker works. You need a Docker image from which you then instantiate a container.

You really should be asking on unraid forums for help here. Your problem is specifically “how to build a docker image from a Dockerfile, in an unraid environment”. It has nothing to do with Caddy, ultimately.

This topic was automatically closed after 30 days. New replies are no longer allowed.