Lets Encrypt not working

1. My Caddy version (caddy -version):


2. How I run Caddy:

a. System environment:

Ubuntu 18.04

b. Command:

sudo ../bin/caddy --config caddy.json

d. My complete Caddyfile:

https://git.ironfractal.xyz {                                                                                                                                                                                                       
        reverse_proxy / {                                                                                                                                                                                     
                fail_duration 300s                                                                                                                                                                                                  
                header_up X-Forwarded-Ssl on                                                                                                                                                                                        

3. The problem I’m having:

Fails to get ssl.

4. Error messages and/or full log output:

2019/12/14 13:22:07 http: TLS handshake error from no certificate available for ‘git.ironfractal.xyz’
2019/12/14 13:22:23 [ERROR] Making new certificate manager: get directory at ‘https://acme-v02.api.letsencrypt.org/directory’: Get https://acme-v02.api.letsencrypt.org/directory: net/http: request canceled while waiting for conn
ection (Client.Timeout exceeded while awaiting headers) (attempt 2/3)

5. What I already tried:

6. Links to relevant resources:

Hi @Mr_Pyro, welcome to the Caddy community.

This error indicates that Caddy wasn’t able to access LetsEncrypt through the internet. Check your internet connection, ensure that the Caddy host server is able to make outbound requests, and double check that LetsEncrypt isn’t being blocked from your network somehow.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.