Jellyfin and Caddy with domain name setup

1. Caddy version (caddy version):

Caddy version 2

2. How I run Caddy:

I run caddy on my raspberry pi with raspberry pi os.

a. System environment:

uname -a

Gives me:

Linux NervHq 5.4.47-v7l+ #1322 SMP Wed Jun 17 17:58:52 BST 2020 armv7l GNU/Linux

Not installed with docker.
Directly installed to system.
Jellyfin running on same raspberry pi.

c. Service/unit/compose file:


d. My complete Caddyfile or JSON config:

Empty as i am using the command line

3. The problem I’m having:

I am trying to get my domain name to connect to my jellyfin install on my raspberry pi from the domain name

4. Error messages and/or full log output:

Running :

sudo iptables -L

Gives me

pi@NervHq:~ $ sudo iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


pi@NervHq:~ $ sudo caddy reverse-proxy --from --to

Gives me the output:

5. What I already tried:

I have tried to remove the CNAME and A Name records in the DNS records from domain com

I have even tried doing a fresh install of raspberry pi os and caddy with jellyfin to no avail.

Welcome Marcos,

Make sure your A record points to your public IP address, and that your router that is assigned that IP address from the WAN will forward ports 80 and 443 to the machine with your Jellyfin process running on it.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.