Impossible to use the site on Chrome

Hello, I’m using Chrome and it is impossible to scroll the page or click any button: do you know of such issue?

No. Caddy won’t alter the response body - unless you told it to do so.

Please fill out the forum’s help template.

Sorry, I was not clear: the problem is with this forum, with Discourse, not Caddy itself.

Ah, your question is in the wrong category then. I changed it to Site Feedback for you.

I am not aware of an issue in Chrome. It works for me…

1 Like

@matt , thank you and sorry…

I have this problem only on this installation of Discourse: I use it on other communities and they work well.

Any idea about how to find the cause of the issue?

Because I’m currently forced to use it from the Discourse app on mobile or from another browser on desktop…

1 Like

Can you reproduce your issue in an incognito session?
Anything interesting in your browser dev console or network tab?

1 Like

@IndeedNotJames , you are right: it works in incognito mode and works also in other Chrome profiles.

It doesn’t work only in my main profile. The strange thing is that it didn’t worked way before I signed up (for a lot of days I simple read the posts, without participating, so no need to have an account here).

Anyway, the console shows this error:

Refused to execute inline script because it violates the following Content Security Policy directive: "script-src https://caddy.community/logs/ https://caddy.community/sidekiq/ https://caddy.community/mini-profiler-resources/ https://caddy.community/assets/ https://caddy.community/brotli_asset/ https://caddy.community/extra-locales/ https://caddy.community/highlight-js/ https://caddy.community/javascripts/ https://caddy.community/plugins/ https://caddy.community/theme-javascripts/ https://caddy.community/svg-sprite/ https://www.google-analytics.com/analytics.js 'sha256-hzxbmvze6p3mvhdzlfai9cumlh+qwx6bnt3qtwnpatg='". Either the 'unsafe-inline' keyword, a hash ('sha256-HZxBMVZe6P3MvHDZlFai9cUmLH+qwX6BNT3qTwNPATg='), or a nonce ('nonce-...') is required to enable inline execution.
1 Like

Did you try disabling any/all Chrome extensions? Since it works Incognito (which doesn’t enable extensions by default) I’m guessing a plugin is trying to execute scripts in-line, which violates a CSP.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.