Illegal Instruction

1. Caddy version (caddy version):

Not sure, since it’s not working.

2. How I run Caddy:

Haven’t been able to run it yet.

a. System environment:

Raspibian OS

pi@zero:~ $ uname -a
Linux zero 5.10.60+ #1449 Wed Aug 25 14:59:20 BST 2021 armv6l GNU/Linux

b. Command:


c. Service/unit/compose file:


d. My complete Caddyfile or JSON config:


3. The problem I’m having:


I’m trying to get caddy working on my respberry Pi Zero, but am receving an error: Illegal Instruction.

I followed these instructions to perform the install, but it doesn’t seem to work, for me.

I then searched and saw this thread which mentions:

You might need a different ARM version (6 instead of 7, probably). Add arm=6 to the download link and it will probably work on your Pi.

I’m therefore wondering how I’d go about installing a specific version for the pi Zero architecture.

4. Error messages and/or full log output:

Illegal Instruction

5. What I already tried:

Uninstalled & reinstalled

You’ll need to grab a build from the download page for the exact architecture you need:

Follow these instructions to only replace the binary, and still be able to use the apt repo for the support files (systemd service, default Caddyfile, user/permissions setup):

The above docs page is part of the “build from source” section, but you don’t need to do that, just follow the instructions there to use dpkg-divert to tell your system to use your other binary instead.

Keep in mind that you’ll need to update Caddy manually each time there’s a new version, you may be able to use the experimental sudo caddy upgrade command, though when a new version is released.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.