Https for domain but http for api path

1. The problem I’m having:

I have caddy working beautifully for my site, reverse proxying HTTPS for all my services. It’s amazing how nicely it works.

However, I have one device (my kobo) that doesn’t seem to like the https access for the link to the calibre-web api. I have calibre-web configured on its own domain, for secure web access.

It is possible to configure caddy so that is served only by HTTPS, but that is accessible by HTTP?

3. Caddy version:

v2.6.4 h1:2hwYqiRwk1tf3VruhMpLcYTg+11fCdr8S3jhNAdnPy8=

4. How I installed and ran Caddy:

a. System environment:

Docker under linux

Enable the debug global option. What do you see in your logs when you try to use your Kobo?

How old is your Kobo? It might be using an outdated (insecure) TLS version if it’s too old.

It is possible to serve it over HTTP, but I strongly recommend figuring out why it’s not working before taking that approach. Turning off security should always be the last resort.

Ah, adding header_up X-Scheme https to that proxy directive worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.