Http_ntlm option resulting in runtime error

1. My Caddy version (caddy version):

2.0 beta 15

2. How I run Caddy:

a. System environment:

Debian as an LXC container under Proxmox, also tested with a VM under proxmox

d. My complete Caddyfile or JSON config: {

reverse_proxy {

header_up Host {http.reverse_proxy.upstream.hostport}

transport http_ntlm {



3. The problem I’m having:

Caddy is failing to start, it throws an error message

4. Error messages and/or full log output:

2020/03/05 02:18:52.595 INFO    using adjacent Caddyfile
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0xb38666]

goroutine 1 [running]:*HTTPTransport).UnmarshalCaddyfile(0x0, 0xc000085dd0, 0x0, 0x0)
        /Users/matt/go/pkg/mod/ +0xf06*Handler).UnmarshalCaddyfile(0xc0000b8a00, 0xc000085d70, 0x3, 0x193f2ca)
        /Users/matt/go/pkg/mod/ +0xde1, 0xc000085b90, 0xc00009a380, 0xc000085d40, 0xc00067fd90, 0x1, 0x1, 0xc00009a340, 0x1, 0x1, ...)
        /Users/matt/go/pkg/mod/ +0x4e, 0xc000085b90, 0xc00009a380, 0xc000085d40, 0xc00067fd90, 0x1, 0x1, 0xc00009a340, 0x1, 0x1, ...)
        /Users/matt/go/pkg/mod/ +0x22b, 0x2, 0x2, 0xc000085b90, 0xc00009a360, 0x1, 0x1, 0x0, 0x0, 0x0)
        /Users/matt/go/pkg/mod/ +0x3bf0, 0x1a33d08, 0xc00067c380, 0x14c, 0x34c, 0xc000085b90, 0xc0003366c0, 0x6400000000fec480, 0xc00073f828, 0x643c68b7ef615a72, ...)
        /Users/matt/go/pkg/mod/ +0x139, 0x9, 0x0, 0x0, 0xc00010c7f8, 0xc0003ce820, 0xd0, 0xd0, 0xf9a020, 0x30)
        /Users/matt/go/pkg/mod/ +0x27f, 0x0, 0x0, 0x0)
        /Users/matt/go/pkg/mod/ +0x8f1
        /Users/matt/go/pkg/mod/ +0x23e
        /Users/matt/Downloads/Downloads/caddytest/main.go:37 +0x20
start: caddy process exited with error: exit status 2

5. What I already tried:

Tried disabling all other directives except the reverse proxy, tried on LXC and VM (just incase). Done lots of googling.


Thanks for the report – and thank you for trying Caddy 2 while it’s still in beta! That’s definitely a bug. Can you do a couple things to help make this faster?

  • Try the latest from the v2 branch, make sure the bug is still present
  • File an issue on GitHub (this way we won’t forget about it)

Then we can look at it more! Thanks for your help!

1 Like

To make this a bit faster, you could use one of the pre-build binaries from CI:


Thanks for this link, I tried the version on that link, same issue. I’ll file with github.

Thanks all!

1 Like

Thank you! Much appreciated. :grinning:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.