How to solve urn:acme:error:rateLimited


I ran the docker-compose -f prodution.yml up -build command several times, after which I had to delete the files of my containers, and now when I try to repeat this, I get an error:

[] failed to get certificate: acme: Error 429 - urn:acme:error:rateLimited - Error creating new cert :: too many certificates already issued for exact set of domains: domain: see

I understand that this is due to limits from LetsEncrypt, but how to solve this problem?
I do not have time to wait, I need to deploy my web application.

I think of two ways to solve this problem:

  1. Disable HTTPS, while there is no time to retrieve the certificate from LetsEncrypt
  2. Buy a premium certificate.

I tried the first method, but the web application was not available:

www.{$DOMAIN_NAME} {

    proxy / myapp:5000 {
        header_upstream Host {host}
        header_upstream X-Real-IP {remote}
        header_upstream X-Forwarded-Proto {scheme}
    log stdout
    errors stdout

Do you have any ideas on how I can get out of this situation as quickly as possible?

Thank you in advance.

If you need to disable HTTPS for this domain while you wait for the rate limits on Let’s Encrypt you can set the tls directive to the off value as described here:

The default port for Caddy when not using automatic HTTPS is 2015 I think, so when you configure your domain without automatic HTTPS (tls off) you will need to either explicitly define the scheme or the port, for example instead of just, to use port 80.

Hi @narnikgamarnikus,

The advice from @Lucas is solid; prepending your site labels with http://, like so:

http://www.{$DOMAIN_NAME} {

http://{$DOMAIN_NAME} {

will both turn off TLS, and serve the site on port 80. Remove the scheme prefix in a week when the rate limits clear.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.