How to Setup Caddy with Ombi on Windows 10

1. Caddy version (caddy version): 1.0.4

2. How I run Caddy:

I just got into reverse proxies and I want to use Caddy to secure Ombi. I have my own domain and I have searched all over forums to try and find a tutorial on how to setup Caddy with Ombi on windows 10, but have found nothing.

3. System environment:

I run Caddy 1.0.4 because it was the easiest Windows 10 tutorial I have found. I use Windows 10 Home, so Docker seems to be out of the question. I went through the tutorial and managed to get Caddy to give my domain a certificate, but when I open a web browser it still says “404 Page Not Found”

4. My complete Caddyfile or JSON config:
proxy /ombi {

5. The problem I’m having:

I cannot find a way to get Caddy to see Ombi. I also do not know if Caddy V2 is the setup on Windows 10 as Caddy V1.

Howdy @The_Spartan, welcome to the Caddy community.

Can you elaborate on this one? What do you mean by “see”?

It might be helpful to ask and answer these three questions:

  1. What did I do? (e.g. browsed to insert exact url here)
  2. What did I expect? (e.g. my upstream app)
  3. What did I get instead? (e.g. my browser gave me insert exact error text here)

It’s not the same - being a complete rewrite from the ground up from v1 to v2, the Caddyfile is structurally quite similar but much syntax has changed.

That said, your current Caddyfile is very simple and the translation would be very easy, the v2 Caddyfile shouldn’t be any more complex.

Hello Whitestrake, I appreciate your prompt response.
I did:
I installed Caddy V1, using their beginners guide. I purchased my own domain ( I added an A list to my domain (I use Dynu) that adds “www” to the beginning of my domain. I tried to direct Caddy to my site, which I am assuming would be the Ombi folder. I used the example Caddyfile from Ombi’s GitHub. Then I port forwarded port 80 and 443 to port 80 and 443 on my Windows computer.
I expected:
To see my Ombi login page from my secure domain.
I got:
I went to my and got the 404 error that is expected when Caddy is working, but missing an index file.

Would you recommend trying to switch to Caddy V2? Would the setup be the same as Caddy V1?
Thank you for helping, I am very new to reverse proxies.

To be clear, this is the behaviour I would expect from your Caddyfile. This part:

Tells Caddy v1 to proxy if the URL path starts with /ombi.

That means a request to your domain name with a path of / (i.e., just typing your domain name in your browser’s URL bar) wouldn’t be proxied at all. It will be handled by the fallback static file handler. The static file server assumes a default web root (that default is whichever directory you run Caddy from) and tries to serve files out of it. Likely you didn’t run Caddy from a folder with an index file, hence the 404.

I would recommend going to v2. V1 is no longer being developed.

Conceptually they’re identical. There are only minor differences to wording (e.g. proxyreverse_proxy, /ombi/ombi*, and no need for transparent as this is v2’s default behaviour). Check out the upgrade guide, though:

This topic was automatically closed after 30 days. New replies are no longer allowed.