Hosting EQDKP with caddy

1. Caddy version (caddy version):

v2.2.1 h1:Q62GWHMtztnvyRU+KPOpw6fNfeCD3SkwH7SfT1Tgt2c=

2. How I run Caddy:

a. System environment:

Distributor ID: Debian
Description: Debian GNU/Linux 10 (buster)
Release: 10
Codename: buster

b. Command:

Using systemd to start it with this command

/usr/bin/caddy run --environ --config /etc/caddy/Caddyfile

c. Service/unit/compose file:


ExecStart=/usr/bin/caddy run --environ --config /etc/caddy/Caddyfile
ExecReload=/usr/bin/caddy reload --config /etc/caddy/Caddyfile


d. My complete Caddyfile or JSON config:

I admit I redacted some stuff here, mainly my other domains, as I think its not very necessary for this kind of problem

  default_sni ""
  email ""

(logging) {
    log {
            output file /var/lib/caddy/log/{host}/access.log

(www_redirect) {
    redir https://www.{host}{uri}

(compression) {
    encode zstd gzip

(phpfpm) {
    php_fastcgi unix//var/run/php/php7.3-fpm.sock

(default_root) {
    import compression
    root * /var/lib/caddy/www/{host}

(file_browser) {
   import compression
   root * /var/lib/caddy/www/{host}
   file_server browse

(default_root_php) {
    import default_root
    import phpfpm

(pretix_proxy) {
    reverse_proxy http://localhost:8345
} {
    import default_root_php

3. The problem I’m having:

I’m trying to host EQDKP, which is a DKP and Gaming CMS. During installation it tells me that the “PathInfo-Support” is not enabled. A Short search on google lead me to this forum post: [1] which hinted towards this wiki article of them: [2]

Problem now is that it tells me some nginx commands and settings and I have no clue of nginx or how to translate it into caddy.

4. Error messages and/or full log output:

5. What I already tried:

Instead of using the php_fastcgi “shortcut” I tried to use the Expanded form but instead of using the split like it is using the regex they suply for ngnix

6. Links to relevant resources:


I think you might be running into this problem:

I’ve opened a PR to fix, but it needs to be reviewed closely before being merged.

To confirm, you could download the build artifact from here to try it out to see if it fixes the problem for you: fastcgi: Avoid changing scriptName when not necessary · caddyserver/caddy@d926587 · GitHub (just swap out the caddy binary with the one from that download and restart Caddy)

Thanks francis that solved the problem.
I hope your PR will get merged soon.


This topic was automatically closed after 30 days. New replies are no longer allowed.