Help configuring Caddy in Portainer

Hello all, I really hope someone can walk me through setting this up. I am very new to anything Linux related (~1 month) but thought it would be fun to build a home NAS using a Raspberry Pi. So far I have been able to get what I wanted out of it which is a media server for family photos and videos using Jellyfin. I’ve also set up SnapRaid and will be adding a third drive for rsync backups too using OMV5.

My issue is that I don’t know much about security and I don’t understand any of the options in Portainer for configuring Caddy to secure my network. I have spent almost two weeks working on this and watching/reading tutorial after tutorial and I feel like I’ve made no progress in getting this up and running.

What do I put in the ‘Manual Network port publishing’ Host block?
What do I put into the advanced options: Command and Logging; Volumes; Environment; Network; Labels etc etc.
How do I know if it’s working? Should I see https when I visit OMV5 through the web browser? or Jellyfin?

So far I have made a DNS on duckDNS and tried plugging it in here and there but like I said I don’t know much about security or even ip routing/mapping. The frustration is starting to kick in now as I can’t seem to figure any of this out.

I know this works in conjunction with letsencrypt also which I would like to get working with it.

Any help is greatly appreciated and please dumb it down for me as I am on a caveman level of understanding; HTTP=Bad, HTTPS=Good.

1. My Caddy version (caddy version): 1.0.3 abiosoft

2. How I run Caddy: Through OMV5/Portainer docker

a. System environment: Raspberry Pi 4. Raspbian Buster Lite.

Thanks in advance

Welcome J –

Have you tried asking the Portainer community? There’s not a whole lot here that’s specific to Caddy.

Sounds like you have the basics down though :slight_smile:

I don’t have experience with Portainer so I’m afraid I can’t be of much help. But if you ask them how to set it up, then they could probably help you more. (Maybe you’ll get lucky and somebody here will know about Portainer, though. But you’d have to get lucky.)

Thanks for the reply Matt. I guess I’ll jump over there and see what they can help with. I just can’t watch another tutorial and still feel lost. It’s driving me crazy.

Matt maybe you could help me with another problem I’ve made. I decided to try to install Caddy via command prompt thinking that following that path may be better than Portainer. I was able to get it installed and am running 1.0.4 but Letsencrypt just gives errors. Either way I’d like to uninstall that version of Caddy from the Pi but can’t seem to find any command for doing it. I’ve tried all the stuff I could find on google and none of it is working.

I don’t want it causing conflicts with the container version.

Thanks again.

Just delete the caddy binary and replace it with the new one. The only installation process (esp. in v1) is one that you make, so there’s no real uninstallation process.

ok so I hope I did it right. I used rm -r /etc/caddy and I think there might have been another folder in usr/bin.

Now when I type in ‘caddy’ I get “command not found” instead of the script about it running HTTP on port 2015.

That means there’s no binary in your PATH. Your PATH is an environment variable that tells the shell where to look for binaries/executables:

echo $PATH

Make sure that an executable binary called caddy is in one of those paths. (Sometimes you have to log out and log back in or start a new shell.)

I think that’s what I was going for by deleting the files. Now when I finally figure out how to configure the Docker it will be the only instance of Caddy running…I hope.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.