Get an SSL certificate when ports 80 and 443 are unavailable on OpenVZ and X-UI panel

1. The problem I’m having:

Get an SSL certificate when ports 80 and 443 are unavailable on OpenVZ
I installed the X-UI panel on a VPS with OpenVZ Debian 10 OS.

IP is not personal. Only ports 15800-15820 are available.

By the panel opens. The task is to configure SSL for the domain.
I installed caddy, it seems to issue SSL automatically when I try to access
But not in my case, because... 443 is not available.

2. Error messages and/or full log output:

The command does not work: journalctl -u caddy --no-pager | less +G`

3. Caddy version:

root@xui:~# caddy version
v2.7.5 h1:HoysvZkLcN2xJExEepaFHK92Qgs7xAiCFydN5x5Hs6Q=

4. How I installed and ran Caddy:

apt install -y debian-keyring debian-archive-keyring apt-transport-https curl

curl -1sLf ‘’ \


curl -1sLf ‘’ \


echo “deb [trusted=yes] /” \ | tee -a /etc/apt/sources.list.d/caddy-fury.list

apt update
sudo apt install caddy

a. System environment:

Debian 10 Minimal Installing whithout docker

b. Command:

systemctl start caddy

c. Service/unit/compose file:

d. My complete Caddy config:

:80 {
        # Set this path to your site's directory.
        root * /usr/share/caddy

        # Enable the static file server.

        # Another common task is to set up a reverse proxy:
        # reverse_proxy localhost:8080

        # Or serve a PHP site through php-fpm:
        # php_fastcgi localhost:9000

5. Links to relevant resources:

If you can’t expose your server publicly on ports 80 and 443, you’ll need to use the ACME DNS challenge to get a certificate.

See How to use DNS provider modules in Caddy 2

And Build from source — Caddy Documentation

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.