Freshrss index.php forbidden for POST?

I’m attempting to run freshRSS via CentOS Linux release 7.9.2009 (Core) the yum install caddy (aka v2.4.1 h1:kAJ0JB5Xk5gPdTH/27S5cyoMGqD5lBAe9yZ8zTjVJa0=).

If I disable FreshRSS’s auth it works, pretty much just fine. So php-fpm is working, as is the mariadb. That’s nice because this kit was working with httpd before I decided to switch to caddy.

I disabled auth because I couldn’t log in. I was planning to try resetting the pass word. But when I do that it announces the page is forbidden 403. It’s doing a POST to /index.php?c=user&a=profile.

So my question is does anybody have FreshRSS working under caddy and might be willing to let me have a glimpse of their config.

Here’s mine at the moment:

# -*- caddyfile -*-

rs.example.net {
    log {
        output file /var/log/caddy/rs.example.net.log {
            roll_size 1gb
            roll_keep 2
            roll_keep_for 72h
        }
    }
    root * /usr/share/FreshRSS/p
    php_fastcgi unix//var/run/php-fpm.sock
    file_server
    header {
        X-Content-Type-Options nosniff
        X-Zippy yowza
        Content-Security-Policy "default-src 'self'"
        Strict-Transport-Security: max-age=63072000
        # Cache-Control private, must-revalidate, max-age=0
    }
    }

Have you confirmed the operation of simple PHP? Probably the same as this case,

Caddy returns 502 if it is not connected to PHP. It looks like PHP is probably returning a 403
I thought it was a problem for users running PHP.
.

It’s unlikely this is a problem with Caddy. Make sure your php-fpm process has the correct permissions to read and execute the files in your PHP app.