Error when using route53

1. Output of

go version: 1.16.5
caddy version: 2.4.6
route53 version: 1.3.0

2. How I run Caddy:

a. System environment: Windows 10

b. Command:

caddy.exe run

c. Service/unit/compose file:

FileName: my.routing.com

(route) {
  tls {
    dns route53 {
      region ...
      access_key_id ...
      secret_access_key ...
    }
  }
}

my.routing.com {
  reverse_proxy staging.routing.com
  import route
}

d. My complete Caddy config:

import my.routing.com

e. main.go file

package main

import (
	caddycmd "github.com/caddyserver/caddy/v2/cmd"

	// plug in Caddy modules here
	_ "github.com/caddyserver/caddy/v2/modules/standard"
	_ "github.com/caddy-dns/route53"
)

func main() {
	caddycmd.Main()
}

3. The problem I’m having:

I trying to use caddy and route53 to automatically renew the certificate through caddy
However, whenever I set and run route53 tls, the following error appears
And when I access the site, I get a warning that it’s not safe

4. Error messages and/or full log output:

2022/11/23 08:11:39.862 e[34mINFOe[0m   tls.issuance.acme       waiting on internal rate limiter        {"identifiers": ["my.routing.com"], "ca": "https://acme-v02.api.letsencrypt.org/directory", "account": ""}
2022/11/23 08:11:39.862 e[34mINFOe[0m   tls.issuance.acme       done waiting on internal rate limiter   {"identifiers": ["my.routing.com"], "ca": "https://acme-v02.api.letsencrypt.org/directory", "account": ""}
2022/11/23 08:11:40.978 e[34mINFOe[0m   tls.issuance.acme.acme_client   trying to solve challenge       {"identifier": "my.routing.com", "challenge_type": "dns-01", "ca": "https://acme-v02.api.letsencrypt.org/directory"}
2022/11/23 08:11:43.056 e[31mERRORe[0m  tls.issuance.acme.acme_client   cleaning up solver      {"identifier": "my.routing.com", "challenge_type": "dns-01", "error": "no memory of presenting a DNS record for my.routing.com (probably OK if presenting failed)"}
2022/11/23 08:11:43.262 e[31mERRORe[0m  tls.obtain      could not get certificate from issuer   {"identifier": "my.routing.com", "issuer": "acme-v02.api.letsencrypt.org-directory", "error": "[my.routing.com] solving challenges: presenting for challenge: adding temporary record for zone routing.com.: Error unquoting TXT/SPF record: invalid syntax (order=https://acme-v02.api.letsencrypt.org/acme/order/732212697/146722220587) (ca=https://acme-v02.api.letsencrypt.org/directory)"}
2022/11/23 08:11:43.264 e[33mWARNe[0m   tls.issuance.zerossl    missing email address for ZeroSSL; it is strongly recommended to set one for next time
2022/11/23 08:11:45.373 e[34mINFOe[0m   tls.issuance.zerossl    generated EAB credentials       {"key_id": "blabla"}

5. What I already tried:

I’ve been searching for information about this for days, but I’ve failed to solve the problem
I’m not sure which one was a meaningful attempt

6. Links to relevant resources:

I wrote a comment here, but Josh said it would be better to create a new post, so I’m creating a new one

Please update to Release v2.6.2 · caddyserver/caddy · GitHub, your version is more than a year old by now :eyes:

On that note, how do you compile Caddy?

Can you share the domain you are having issues with without redacting it?

1 Like