Error when starting Caddy using duckdns

1. Output of caddy version:

When i do ‘caddy version’ nothing pops up.

2. How I run Caddy:

a. System environment:

Fedora server edition 37, with docker

b. Command:

sudo caddy run --config Caddyfile

c. Service/unit/compose file:

Using docker

d. My complete Caddy config: {
	reverse_proxy localhost:8096
	tls {
		dns duckdns (token)

3. The problem I’m having:

I can’t start caddy because it gives me this error

4. Error messages and/or full log output:

2022/12/02 18:53:08.294 INFO    using provided configuration    {"config_file": "Caddyfile", "config_adapter": ""}
2022/12/02 18:53:08.295 INFO    admin   admin endpoint started  {"address": "tcp/localhost:2019", "enforce_origin": false, "origins": ["//localhost:2019", "//[::1]:2019", "//"]}
2022/12/02 18:53:08.295 INFO    http    server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS {"server_name": "srv0", "https_port": 443}
2022/12/02 18:53:08.295 INFO    http    enabling automatic HTTP->HTTPS redirects        {"server_name": "srv0"}
2022/12/02 18:53:08.295 INFO    tls.cache.maintenance   started background certificate maintenance      {"cache": "0xc0000347e0"}
2022/12/02 18:53:08.296 INFO    tls     cleaning storage unit   {"description": "FileStorage:/root/.local/share/caddy"}
2022/12/02 18:53:08.296 INFO    http    enabling automatic TLS certificate management   {"domains": [""]}
2022/12/02 18:53:08.296 INFO    tls     finished cleaning storage units
2022/12/02 18:53:08.296 INFO    autosaved config (load with --resume flag)      {"file": "/root/.config/caddy/autosave.json"}
2022/12/02 18:53:08.296 INFO    serving initial configuration
2022/12/02 18:53:08.296 INFO    tls.obtain      acquiring lock  {"identifier": ""}
2022/12/02 18:53:08.737 INFO    tls.obtain      lock acquired   {"identifier": ""}
2022/12/02 18:53:08.738 INFO    tls.issuance.acme       waiting on internal rate limiter        {"identifiers": [""], "ca": "", "account": ""}
2022/12/02 18:53:08.738 INFO    tls.issuance.acme       done waiting on internal rate limiter   {"identifiers": [""], "ca": "", "account": ""}
2022/12/02 18:53:09.666 ERROR   tls.obtain      could not get certificate from issuer   {"identifier": "", "issuer": "", "error": "HTTP 429 urn:ietf:params:acme:error:rateLimited - Error creating new order :: too many failed authorizations recently: see"}
2022/12/02 18:53:09.667 INFO    tls.issuance.acme       waiting on internal rate limiter        {"identifiers": [""], "ca": "", "account": ""}
2022/12/02 18:53:09.668 INFO    tls.issuance.acme       done waiting on internal rate limiter   {"identifiers": [""], "ca": "", "account": ""}
2022/12/02 18:53:16.941 INFO    tls.issuance.acme.acme_client   trying to solve challenge       {"identifier": "", "challenge_type": "http-01", "ca": ""}

5. What I already tried:

If tried some diffrent Caddyfiles but it all didn’t work.

6. Links to relevant resources:

If you’re running Caddy in Docker, then you can run docker exec <container-name> caddy version to check the version.

You haven’t completely filled out the help topic template, so it’s ambiguous how you’re actually running Caddy and how you installed it. Please fill that out properly. Be as specific as possible.

This just says you got rate limited by Let’s Encrypt. Caddy will retry with ZeroSSL afterwards which has no rate limits, so that should not be a blocker.

There’s not really enough evidence in your post of any problem.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.