Error: unkwon shorthand flag: 'e' in envfile

1. Output of caddy version:

v2.6.2 hl:wKoFIxpmOJLGl3QXoo6PNbYvGW4xLEgo32PBEjWL8o=

2. How I run Caddy:

Caddyfile:
{$DOMAIN}:443 {
tls {
dns duckdns {$DUCKDNS_TOKEN}
}
reverse_proxy localhost:8080
reverse_proxy /notifications/hub localhost:3012
}

caddy.env:
DOMAIN=starkbau.duckdns.org
DUCKDNS_TOKEN=0000000-0000-0000-00000-aabbccddeeff

a. System environment:

Debian 11, amd64
Docker 10.10.5+dfsgl
systemd 247.3-7+debllul

b. Command:

caddy run -envfile caddy.env

c. Service/unit/compose file:

Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane. -->

d. My complete Caddy config:

Paste your config here, replacing this text.
Use `caddy fmt` to make it readable.
DO NOT REDACT anything except credentials.
LEAVE DOMAIN NAMES INTACT.
Make sure the backticks stay on their own lines.

3. The problem I’m having:

I’m trying to get vaultwarden working on the local network only, following this guide:

I downloaded the duckdns caddy version from here:

and now get the following error:
Error: unkwon shorthand flag: ‘e’ in envfile

4. Error messages and/or full log output:

Error: unkwon shorthand flag: 'e' in envfile

5. What I already tried:

6. Links to relevant resources:

If I put the domain and the token directly into the caddyfile it works!
Is this a security risk in anyway?

You mean, caddy run --envfile caddy.env

Flags have 2 dashes. (Shorthand flags have one, but the only one I think we have is -h for help.)

1 Like