DuckDNS subdomain suddenly stopped working after 9 months. No changes

1. The problem I’m having:

Everything was working perfectly then suddenly stopped. I checked duckdns.org and found the whole domain was down. But it was back up soon after but now its been 3-4 days and my subdomain still isn’t working at all.

I’m very new to all this so would really love some help in how to troubleshoot (find out if the issue is Caddy or DuckDNS or other)

2. Error messages and/or full log output:

My Subdomain websites Example.duckdns.org no longer loads. Here is the logs from Portainer if that helps:

2024-06-24T11:20:27.571962608Z INF ts=1719228027.5715797 msg=shutting down apps, then terminating signal=SIGTERM
2024-06-24T11:20:27.572054427Z WRN ts=1719228027.5716507 msg=exiting; byeee!! 👋 signal=SIGTERM
2024-06-24T11:20:27.572568823Z INF ts=1719228027.571774 logger=http msg=servers shutting down with eternal grace period
2024-06-24T11:20:27.575798887Z INF ts=1719228027.572593 logger=admin msg=stopped previous server address=localhost:2019
2024-06-24T11:20:27.575852697Z INF ts=1719228027.5726385 msg=shutdown complete signal=SIGTERM exit_code=0
2024-06-24T11:20:28.597878447Z INF ts=1719228028.6977108 msg=using provided configuration config_file=/etc/caddy/Caddyfile config_adapter=
2024-06-24T11:20:28.659908358Z WRN ts=1719228028.6998355 msg=Caddyfile input is not formatted; run 'caddy fmt --overwrite' to fix inconsistencies adapter=caddyfile file=/etc/caddy/Caddyfile line=6
2024-06-24T11:20:28.751115310Z INF ts=1719228028.7009866 logger=admin msg=admin endpoint started address=localhost:2019 enforce_origin=false origins=["//localhost:2019","//[::1]:2019","//127.0.0.1:2019"]
2024-06-24T11:20:28.702565787Z INF ts=1719528028.7022178 logger=http.auto_https msg=server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS server_name=srv0 https_port=443
2024-06-24T11:20:28.702358159Z INF ts=1719528028.7022946 logger=http.auto_https msg=enabling automatic HTTP->HTTPS redirects server_name=srv0
2024-06-24T11:20:28.702415974Z INF ts=1719258028.7023413 logger=tls.cache.maintenance msg=started background certificate maintenance cache=0xc000536000
2024-06-24T11:20:28.703550805Z INF ts=1719258028.703068 logger=tls msg=cleaning storage unit description=FileStorage:/root/.local/share/caddy
2024-06-24T11:20:28.703175173Z INF ts=1719225028.7030907 logger=http msg=enabling HTTP/3 listener addr=:443
2024-06-24T11:20:28.703394617Z INF ts=1719228028.7033148 logger=http.log msg=server running name=srv0 protocols=["h1","h2","h3"]
2024-06-24T11:20:28.703473728Z INF ts=1719228028.7033954 logger=http.log msg=server running name=remaining_auto_https_redirects protocols=["h1","h2","h3"]
2024-06-24T11:20:28.703502038Z INF ts=1719228028.7034092 logger=http msg=enabling automatic TLS certificate management domains=["example.duckdns.org","example2.org","example3.duckdns.org"]
2024-06-24T11:20:28.704831925Z INF ts=1719228028.7047338 logger=tls msg=finished cleaning storage units
2024-06-24T11:20:28.705948833Z INF ts=1719228028.7058265 msg=autosaved config (load with --resume flag) file=/root/.config/caddy/autosave.json
2024-06-24T11:20:28.705969289Z INF ts=1719228028.7058413 msg=serving initial configuration

3. Caddy version:

2.7.4 (or close to that. Definetly 2.7.x)

4. How I installed and ran Caddy:

It was months ago. But something to do with Xcaddy building a file and installing it with dockercompose in portainer. This was to use the DuckDNS plugin I believe.

a. System environment:

Macbook Pro - OMV - Docker -

b. Command:

I usually just use Portainer to avoid commands, since its more Newb friendly.

c. Service/unit/compose file:

Nothing was changed. This was working perfectly before.

caddy:
    image: custom-caddy:latest
    restart: unless-stopped
    container_name: caddy
    cap_add:
      - NET_ADMIN
    environment:
      - LOG_LEVEL=debug
      - TZ=Australia/Sydney
    ports:
      - 69:69
      - 443:443
    volumes:
      - /media/USB/data/caddy/Caddyfile:/etc/caddy/Caddyfile
      - /media/USB/data/caddy/data:/data # Optional
      - /media/USB/data/caddy/config:/config # Optional
      - /media/USB/data/caddy/site:/srv
    networks:
      - Jelly

d. My complete Caddy config:

Nothing was changed. This was working perfectly before.

{
	http_port 69
	https_port 443
}
example.duckdns.org {
reverse_proxy 192.168.1.111:8096

tls {
    dns duckdns 2c811663-fake-4ce2-not-27notrealc4

}
}
example2.duckdns.org {
reverse_proxy 192.168.1.111:5055

tls {
    dns duckdns 2c811663-fake-4ce2-not-27notrealc4
}
}

example3.duckdns.org {
reverse_proxy 192.168.1.111:9090

tls {
    dns duckdns 2c811663-fake-4ce2-not-27notrealc4
}
}

5. Links to relevant resources:

NA
I looked at some old similar wiki questions and the documentation but I don’t really speak this tech language very well and need a more custom point in the right direction please.

I don’t see any errors in your logs. I don’t know what you’re trying to say is the problem. Please show evidence of the actual problem.

1 Like

Just the website not working. Tested on multiple different browsers and machines. Standard “This site can’t be reached” error. I blocked out the full URL for privacy. I’ve also tried rebooting the container and the whole server several times. And double checked that the Port FWD settings are still on the modem.

How would I go about troubleshooting this? The issue might be with DUCKDNS, but going to https://www.duckdns.org/ seems to work fine now.

I really appreciate the help and I’m sorry that I’m not knowledgeable enough to give more details. I’m really trying my best.

I was having issues with my duckdns subdomain yesterday. It looks like they had some sort of issue and it took a while to propagate the fix.

You can check to see if your subdomain is being resolved and where there’s still issues here DNS Checker - DNS Check Propagation Tool

If the main domain works, but the subdomain doesn’t then that’s exactly what happened to me. I just had to wait for the dns to propagate the fix.

1 Like

Thanks very much. Almost all of them seem green. Any other ideas I can use to troubleshoot? How long was yours down for? Its about 5 days for me now.

Just adding some extra info: I tried logging in with VPNs from different countries. And the server is working fine locally.

Fixed it! Terribly sorry for bothering everyone. Caddy wasn’t the issue at all.

What happened was that DuckDNS had a drop out, but before I figured that out I tried to trouble shoot (including restarting my modem). This changed the IP address that DUCKDNS was looking at. I needed to just go into the modem, grab the IP and update it in DuckDNS.

Sorry for the troubles!

1 Like