Drag and drop for file server

1. Caddy version (caddy version):

v2.3.0

2. How I run Caddy:

I am running caddy as a file server locally for now

a. System environment:

Centos 7

b. Command:

caddy run

c. Service/unit/compose file:

paste full file contents here

d. My complete Caddyfile or JSON config:

:2015

root * /home/admin/Documents 

file_server browse

3. The problem I’m having:

I am trying to allow for simple drag and drop of files to the specified directory for upload, but it does not seem to be working.

I don’t know if this can be achieved with caddy.

4. Error messages and/or full log output:

None

5. What I already tried:

I have changed the file permission for the folder that I am using but no luck

6. Links to relevant resources:

Caddy’s file_server does not support file upload.

I’d recommend using something like GitHub - filebrowser/filebrowser: 📂 Web File Browser for this instead (and you can use reverse_proxy to put Caddy in front of it).

1 Like

Thank you for the quick response, I will look into it!